aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-04 18:04:17 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-04 18:10:53 +0000
commit4cda17ab14588e6e4fdac7f697e246554ce82af3 (patch)
tree195f484089a2439c7326ee3f5a1335d4470f90f8 /Mk
parentcfff80b52944431db967c926c6c361cf3c17ff9f (diff)
downloadports-4cda17ab14588e6e4fdac7f697e246554ce82af3.tar.gz
ports-4cda17ab14588e6e4fdac7f697e246554ce82af3.zip
*/*: Refactor java/openjdk7 removal
- java/openjdk7* has been removed from the tree since 2022-09-03 however the relevant codebases in bsd.java.mk has not been removed and the consumers has also not been updated to use the next jdk version. This commit updates all relevant consumers to use JAVA_VERSION=8 instead of JAVA_VERSION=1.7 - Since the introduction of jdk version 18 it looks like similar with jdk version 8(java version string 1.8). This is prone to error as it looks similar and is only seperated by a '.'. Remove using JAVA_VERSION with dotted fomat of java version string and update all consumers to utilize version 8 instead of 1.8. Approved by: portmgr (blanket)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.java.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.java.mk b/Mk/bsd.java.mk
index ca8cbf940c7c..78ecd65408ba 100644
--- a/Mk/bsd.java.mk
+++ b/Mk/bsd.java.mk
@@ -22,7 +22,7 @@ Java_Include_MAINTAINER= java@FreeBSD.org
#
# JAVA_VERSION List of space-separated suitable java versions for the
# port. An optional "+" allows you to specify a range of
-# versions. (allowed values: 7[+] 8[+] 11[+] 17[+] 18[+])
+# versions. (allowed values: 8[+] 11[+] 17[+] 18[+])
#
# JAVA_OS List of space-separated suitable JDK port operating systems
# for the port. (allowed values: native linux)
@@ -159,7 +159,7 @@ SUB_LIST+= JAVA_OS="${JAVA_OS}"
. endif
# The complete list of Java versions, os and vendors supported.
-__JAVA_VERSION_LIST= 7 8 11 17 18
+__JAVA_VERSION_LIST= 8 11 17 18
_JAVA_VERSION_LIST= ${__JAVA_VERSION_LIST} ${__JAVA_VERSION_LIST:S/$/+/}
_JAVA_OS_LIST= native linux
_JAVA_VENDOR_LIST= openjdk oracle
@@ -265,7 +265,7 @@ JAVA_RUN= jre
. undef _JAVA_PORTS_INSTALLED
. undef _JAVA_PORTS_POSSIBLE
. if defined(JAVA_VERSION)
-_JAVA_VERSION= ${JAVA_VERSION:S/^1.7+/1.7 1.8+/:S/^1.8+/1.8 11+/:S/^1.7/7/:S/^1.8/8/:S/^7+/7 8+/:S/^8+/8 11+/:S/^11+/11 17+/:S/^17+/17 18+/:S/^18+/18/}
+_JAVA_VERSION= ${JAVA_VERSION:S/^8+/8 11+/:S/^11+/11 17+/:S/^17+/17 18+/:S/^18+/18/}
. else
_JAVA_VERSION= ${__JAVA_VERSION_LIST}
. endif