aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2017-04-03 17:33:48 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2017-04-03 17:33:48 +0000
commit56cab9fcdb3c1d707d1101acaad0fd6fe7996d03 (patch)
tree782d9fe8a3e3be1925e89134d9899c3e1182707e /Mk
parentf3c259369bd432b1ac60ba9fd45b1124e679ecac (diff)
downloadports-56cab9fcdb3c1d707d1101acaad0fd6fe7996d03.tar.gz
ports-56cab9fcdb3c1d707d1101acaad0fd6fe7996d03.zip
Remove obsolete OpenSSL hacks for IDEA crypto.
We have some hacks in the ports tree to detect or to unconditionally disable IDEA crypto support. These hacks existed because OpenSSL in FreeBSD 9.3 and earlier was shipped without IDEA support by default but we were allowed to enable it via WITH_IDEA src.conf(5) option. https://www.freebsd.org/cgi/man.cgi?query=src.conf&manpath=FreeBSD+9.3-RELEASE Therefore, we had to implement some hacks to support three different cases, i.e., a) 9.3 and earlier without IDEA crypto (default), b) 9.3 and earlier with IDEA crypto (via WITH_IDEA src.conf option), and c) 10.0 and later with unconditional IDEA support. Now we can safely remove them because 9.3 and earlier is no longer supported. PR: 218233 Exp-Run by: antoine Approved by: antoine (portmgr)
Notes
Notes: svn path=/head/; revision=437668
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/ssl.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/Mk/Uses/ssl.mk b/Mk/Uses/ssl.mk
index 24005d0086e2..ac034a492dd1 100644
--- a/Mk/Uses/ssl.mk
+++ b/Mk/Uses/ssl.mk
@@ -64,24 +64,6 @@ check-depends::
@${FALSE}
. endif
-# OpenSSL in the base system may not include IDEA for patent licensing reasons.
-. if defined(MAKE_IDEA) && !defined(OPENSSL_IDEA)
-OPENSSL_IDEA= ${MAKE_IDEA}
-. else
-OPENSSL_IDEA?= NO
-. endif
-
-. if ${OPENSSL_IDEA} == "NO"
-# XXX This is a hack to work around the fact that /etc/make.conf clobbers
-# our CFLAGS. It might not be enough for all future ports.
-. if defined(HAS_CONFIGURE)
-CFLAGS+= -DNO_IDEA
-. else
-OPENSSL_CFLAGS+= -DNO_IDEA
-. endif
-MAKE_ARGS+= OPENSSL_CFLAGS="${OPENSSL_CFLAGS}"
-. endif
-
.else # ${SSL_DEFAULT} != base
OPENSSLBASE= ${LOCALBASE}