aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-03-29 07:42:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-03-29 07:42:20 +0000
commit6b1ccfbb27429ab81755485f819ee57d1bedd59e (patch)
tree3a46ed48ad3e7e8f06a57cfc9a66cae50df8b726 /Mk
parent12cfd2545ebe7554a4e5690ce6bc58e7a284a674 (diff)
downloadports-6b1ccfbb27429ab81755485f819ee57d1bedd59e.tar.gz
ports-6b1ccfbb27429ab81755485f819ee57d1bedd59e.zip
Remove upgrade script
It never actually really have been a thing, and can be done directly in install/deinstall scripts Reviewed by: mat (portmgr) Differential Revision: https://reviews.freebsd.org/D29427
Notes
Notes: svn path=/head/; revision=569436
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Scripts/create-manifest.sh11
-rw-r--r--Mk/bsd.port.mk6
2 files changed, 5 insertions, 12 deletions
diff --git a/Mk/Scripts/create-manifest.sh b/Mk/Scripts/create-manifest.sh
index 5df9368a1945..18ac5a035b0f 100644
--- a/Mk/Scripts/create-manifest.sh
+++ b/Mk/Scripts/create-manifest.sh
@@ -12,10 +12,9 @@ validate_env dp_ACTUAL_PACKAGE_DEPENDS dp_CATEGORIES dp_COMMENT \
dp_COMPLETE_OPTIONS_LIST dp_DEPRECATED dp_DESCR dp_EXPIRATION_DATE \
dp_GROUPS dp_LICENSE dp_LICENSE_COMB dp_MAINTAINER dp_METADIR \
dp_NO_ARCH dp_PKGBASE dp_PKGDEINSTALL dp_PKGINSTALL dp_PKGMESSAGES \
- dp_PKGORIGIN dp_PKGPOSTDEINSTALL dp_PKGPOSTINSTALL dp_PKGPOSTUPGRADE \
- dp_PKGPREDEINSTALL dp_PKGPREINSTALL dp_PKGPREUPGRADE dp_PKGUPGRADE \
- dp_PKGVERSION dp_PKG_BIN dp_PKG_IGNORE_DEPENDS dp_PKG_NOTES \
- dp_PORT_OPTIONS dp_PREFIX dp_USERS dp_WWW
+ dp_PKGORIGIN dp_PKGPOSTDEINSTALL dp_PKGPOSTINSTALL dp_PKGPREDEINSTALL \
+ dp_PKGPREINSTALL dp_PKGVERSION dp_PKG_BIN dp_PKG_IGNORE_DEPENDS \
+ dp_PKG_NOTES dp_PORT_OPTIONS dp_PREFIX dp_USERS dp_WWW
[ -n "${DEBUG_MK_SCRIPTS}" -o -n "${DEBUG_MK_SCRIPTS_CREATE_MANIFEST}" ] && set -x
@@ -92,7 +91,7 @@ cp ${dp_DESCR} ${dp_METADIR}/+DESC
# Concatenate all the scripts
output_files=
-for stage in INSTALL DEINSTALL UPGRADE; do
+for stage in INSTALL DEINSTALL; do
for prepost in '' PRE POST; do
output=${dp_METADIR}/+${prepost:+${prepost}_}${stage}
[ -f "${output}" ] && output_files="${output_files:+${output_files} }${output}"
@@ -100,7 +99,7 @@ for stage in INSTALL DEINSTALL UPGRADE; do
done
[ -n "${output_files}" ] && rm -f ${output_files}
-for stage in INSTALL DEINSTALL UPGRADE; do
+for stage in INSTALL DEINSTALL; do
for prepost in '' PRE POST; do
eval files="\${dp_PKG${prepost}${stage}}"
output=${dp_METADIR}/+${prepost:+${prepost}_}${stage}
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 5ca45a2ab888..3effd6adf7a6 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1933,9 +1933,6 @@ PKGPREINSTALL?= ${PKGDIR}/pkg-pre-install
PKGPOSTINSTALL?= ${PKGDIR}/pkg-post-install
PKGPREDEINSTALL?= ${PKGDIR}/pkg-pre-deinstall
PKGPOSTDEINSTALL?= ${PKGDIR}/pkg-post-deinstall
-PKGPREUPGRADE?= ${PKGDIR}/pkg-pre-upgrade
-PKGPOSTUPGRADE?= ${PKGDIR}/pkg-post-upgrade
-PKGUPGRADE?= ${PKGDIR}/pkg-upgrade
_FORCE_POST_PATTERNS= rmdir kldxref mkfontscale mkfontdir fc-cache \
fonts.dir fonts.scale gtk-update-icon-cache \
@@ -4344,11 +4341,8 @@ create-manifest:
dp_PKGORIGIN='${PKGORIGIN}' \
dp_PKGPOSTDEINSTALL='${PKGPOSTDEINSTALL}' \
dp_PKGPOSTINSTALL='${PKGPOSTINSTALL}' \
- dp_PKGPOSTUPGRADE='${PKGPOSTUPGRADE}' \
dp_PKGPREDEINSTALL='${PKGPREDEINSTALL}' \
dp_PKGPREINSTALL='${PKGPREINSTALL}' \
- dp_PKGPREUPGRADE='${PKGPREUPGRADE}' \
- dp_PKGUPGRADE='${PKGUPGRADE}' \
dp_PKGVERSION='${PKGVERSION}' \
dp_PKG_BIN='${PKG_BIN}' \
dp_PKG_IGNORE_DEPENDS='${PKG_IGNORE_DEPENDS}' \