aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-01-30 20:00:06 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-01-30 20:00:06 +0000
commit83209114b829704b4d3c22ef757562bf4dccb87f (patch)
treee98e67db95539e3488dc72a5a10fdb491eebff0a /Mk
parent48fb3a37baba14beea150f0ae67404564d405f9a (diff)
downloadports-83209114b829704b4d3c22ef757562bf4dccb87f.tar.gz
ports-83209114b829704b4d3c22ef757562bf4dccb87f.zip
lang/rust: Update to 1.41.0
- Force rebuild all consumers to catch regressions early - Switch to cross-compiled (from amd64) bootstraps for all architectures generated with the incoming lang/rust-bootstrap - Update cargo-c to 0.5.2 to unbreak librav1e build - Make use of regular MAKE_ENV/TEST_ENV in lang/rust - Turn on RUST_BACKTRACE in lang/rust and USES=cargo to hopefully produce more useful failure logs when something panics during builds Changes: https://blog.rust-lang.org/2020/01/30/Rust-1.41.0.html Tested by: mikael, tobik With hat: rust Differential Revision: https://reviews.freebsd.org/D23385
Notes
Notes: svn path=/head/; revision=524658
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cargo.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index 40532d3cbac6..e98ad9b58c2e 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -43,7 +43,7 @@ DISTFILES+= ${CARGO_DIST_SUBDIR}/${_crate}.tar.gz:cargo_${_crate:C/[^a-zA-Z0-9_]
CARGO_BUILDDEP?= yes
.if ${CARGO_BUILDDEP:tl} == "yes"
-BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.40.0:lang/${RUST_DEFAULT}
+BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.41.0:lang/${RUST_DEFAULT}
.endif
# Location of cargo binary (default to lang/rust's Cargo binary)
@@ -56,6 +56,7 @@ CARGO_TARGET_DIR?= ${WRKDIR}/target
# - CARGO_HOME: local cache of the registry index
# - CARGO_BUILD_JOBS: configure number of jobs to run
# - CARGO_TARGET_DIR: location of where to place all generated artifacts
+# - RUST_BACKTRACE: produce backtraces when something in the build panics
# - RUSTC: path of rustc binary (default to lang/rust)
# - RUSTDOC: path of rustdoc binary (default to lang/rust)
# - RUSTFLAGS: custom flags to pass to all compiler invocations that Cargo performs
@@ -63,6 +64,7 @@ CARGO_ENV+= \
CARGO_HOME=${WRKDIR}/cargo-home \
CARGO_BUILD_JOBS=${MAKE_JOBS_NUMBER} \
CARGO_TARGET_DIR=${CARGO_TARGET_DIR} \
+ RUST_BACKTRACE=1 \
RUSTC=${LOCALBASE}/bin/rustc \
RUSTDOC=${LOCALBASE}/bin/rustdoc \
RUSTFLAGS="${RUSTFLAGS} -C linker=${CC:Q} ${LDFLAGS:C/.+/-C link-arg=&/}"
@@ -279,13 +281,11 @@ do-build:
do-install:
. for path in ${CARGO_INSTALL_PATH}
@${CARGO_CARGO_RUN} install \
+ --no-track \
--path "${path}" \
--root "${STAGEDIR}${PREFIX}" \
--verbose \
${CARGO_INSTALL_ARGS}
-# Replace with --no-track once it is part of lang/rust
- @${RM} -- "${STAGEDIR}${PREFIX}/.crates.toml"
- @${RM} -- "${STAGEDIR}${PREFIX}/.crates2.json"
. endfor
.endif