aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2021-08-13 20:36:12 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2021-08-14 00:26:16 +0000
commit8ec588d8f0913d22427baaaacd91b08111e5a2c5 (patch)
tree592b2279fde620270b208b6062b95a1e2bf0c7ce /Mk
parenta9bf6e05715247ac5bd90405b90bfebd6af35c29 (diff)
downloadports-8ec588d8f0913d22427baaaacd91b08111e5a2c5.tar.gz
ports-8ec588d8f0913d22427baaaacd91b08111e5a2c5.zip
Mk/bsd.port.mk: Fix another typo
Reported by: grembo Fixes: 154492dd1f ("Clarify UNAME_r failure.")
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1135e6292e90..261a775219fb 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1196,7 +1196,7 @@ _OSVERSION_MAJOR= ${OSVERSION:C/([0-9]?[0-9])([0-9][0-9])[0-9]{3}/\1/}
.if !defined(.MAKEOVERRIDES) || !${.MAKEOVERRIDES:MOSVERSION}
.if ${_OSVERSION_MAJOR} != ${_OSRELEASE:R}
.if defined(I_DONT_CARE_IF_MY_BUILDS_TARGET_THE_WRONG_RELEASE)
-WARNING+= "I_DONT_CARE_IF_MY_BUILDS_TARGET_THE_WRONG_RELEASE set: Expect unexpected problems as the chroot/jail file versions do not match what `uname` returns. Thus buids will target the wrong release."
+WARNING+= "I_DONT_CARE_IF_MY_BUILDS_TARGET_THE_WRONG_RELEASE set: Expect unexpected problems as the chroot/jail file versions do not match what `uname` returns. Thus builds may target the wrong release if they use `uname`."
.else
.error UNAME_r (${_OSRELEASE}) and OSVERSION (${OSVERSION}) do not agree on major version number: This means your jail or chroot is misconfigured such that the installed files (OSVERION) do not match what `uname -r` (kernel) returns. Likely setting UNAME_r will resolve the issue. OSVERSION should not be set as it will be read from /usr/include/sys/param.h.
.endif