aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-06-11 11:59:55 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-06-11 11:59:55 +0000
commita59094b3536d16cc2e764dfcc7033543d0316ba8 (patch)
tree181c86370f0ab6ba037c93361a60aa11307be5f0 /Mk
parentdad0a7e2048421c78d55971c530a1901666e2ac2 (diff)
downloadports-a59094b3536d16cc2e764dfcc7033543d0316ba8.tar.gz
ports-a59094b3536d16cc2e764dfcc7033543d0316ba8.zip
Add www/qt5-websockets.
The QtWebSockets module implements the WebSocket protocol as specified in RFC 6455. It solely depends on Qt (no external dependencies). http://doc.qt.io/qt-5/qtwebsockets-index.html Submitted by: Tobias Berner <tcberner@gmail.com>
Notes
Notes: svn path=/head/; revision=389193
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.qt.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index f1cb5e5e2b4f..33d109891ebc 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -96,7 +96,7 @@ USES+= tar:xz
# devel/qt*/distinfo for every port.
QT_DIST= base declarative doc graphicaleffects imageformats \
multimedia quick1 quickcontrols script serialport svg tools \
- translations webkit webkit-examples x11extras xmlpatterns
+ translations webchannel webkit webkit-examples websockets x11extras xmlpatterns
. endif
. if ${QT_DIST} == "base" && ${PORTNAME} != "qmake"
@@ -301,7 +301,8 @@ _USE_QT4_ONLY= accessible assistant-adp assistantclient codecs-cn codecs-jp \
_USE_QT5_ONLY= buildtools concurrent core graphicaleffects \
paths phonon4 printsupport qdbus qdoc qev qml quick \
- quickcontrols serialport uitools webchannel widgets x11extras
+ quickcontrols serialport uitools webchannel websockets \
+ widgets x11extras
accessible_PORT= accessibility/${_QT_RELNAME}-accessible
accessible_PATH= ${QT_PLUGINDIR}/accessible/libqtaccessiblewidgets.so
@@ -518,6 +519,9 @@ uitools_PATH= ${QT_LIBDIR}/libQt${_QT_LIBVER}UiTools.a
webchannel_PORT= www/${_QT_RELNAME}-webchannel
webchannel_PATH= ${QT_LIBDIR}/libQt${_QT_LIBVER}WebChannel.so
+websockets_PORT= www/${_QT_RELNAME}-websockets
+websockets_PATH= ${QT_LIBDIR}/libQt${_QT_LIBVER}WebSockets.so
+
webkit_PORT= www/webkit-${_QT_RELNAME}
webkit_PATH= ${QT_LIBDIR}/libQt${_QT_LIBVER}WebKit.so