aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-06-05 23:29:11 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-06-05 23:29:11 +0000
commita9fb6a5b22d0ddc21c6a49e7207f2ff2ed3ee494 (patch)
tree2d826ba82391c1c309accdf6184a4c06f4877e98 /Mk
parent3dc82dad2742ee0631421f26674b349a3c6da590 (diff)
downloadports-a9fb6a5b22d0ddc21c6a49e7207f2ff2ed3ee494.tar.gz
ports-a9fb6a5b22d0ddc21c6a49e7207f2ff2ed3ee494.zip
- Replace .error with BROKEN.
PR: ports/68569 Submitted by: eik Approved by: maintainer timeout (almost 1 year)
Notes
Notes: svn path=/head/; revision=136872
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.ruby.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 52763942de67..c63e436de039 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -114,12 +114,12 @@ RUBY_VER?= ${RUBY_DEFAULT_VER}
.if defined(RUBY)
.if !exists(${RUBY})
-.error You set the variable RUBY to "${RUBY}", but it does not seem to exist. Please specify an already installed ruby executable.
+BROKEN= "You set the variable RUBY to \"${RUBY}\", but it does not seem to exist. Please specify an already installed ruby executable."
.endif
_RUBY_TEST!= ${RUBY} -e 'begin; require "rbconfig"; rescue LoadError; puts "error"; end'
.if !empty(_RUBY_TEST)
-.error You set the variable RUBY to "${RUBY}", but it failed to include rbconfig. Please specify a properly installed ruby executable.
+BROKEN= "You set the variable RUBY to \"${RUBY}\", but it failed to include rbconfig. Please specify a properly installed ruby executable."
.endif
_RUBY_CONFIG= ${RUBY} -r rbconfig -e 'C = Config::CONFIG' -e
@@ -143,7 +143,7 @@ RUBY_VERSION?= 1.8.2
RUBY_WRKSRC= ${WRKDIR}/ruby-${RUBY_VERSION}
#MASTER_SITE_SUBDIR_RUBY= snapshots
.elif defined(RUBY_VER) && ${RUBY_VER} == 1.7
-.error "Ruby 1.7 is obsolete; set RUBY_VER to 1.8 instead."
+BROKEN= "Ruby 1.7 is obsolete; set RUBY_VER to 1.8 instead."
.else
RUBY_VERSION?= 1.6.8
RUBY_DISTVERSION?= ${RUBY_VERSION}-2004.07.28