aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-08-03 09:28:57 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-08-03 09:28:57 +0000
commitc6bcad2436d925c98052ed292bd0794ae0e34b45 (patch)
tree4752ebd6e8eb5959ebf00516e4ecf7156215bbce /Mk
parentfbd121eee966abfc21d176cbede935ecd6bf1a34 (diff)
downloadports-c6bcad2436d925c98052ed292bd0794ae0e34b45.tar.gz
ports-c6bcad2436d925c98052ed292bd0794ae0e34b45.zip
(1) Add new variable, XFREE86_VERSION, to specify which version of
XFree86 (3 or 4) to depend to when USE_XLIB is set. XFREE86_VERSION defaults to 3 for now, but adventurous users can override it in /etc/make.conf. When XFREE86_VERSION=3, USE_XLIB will add a dependency to x11/XFree86; when it is set to 4, the dependency will be to x11/XFree86-4-libraries. When XFREE86_VERSION=4, the PKG_IGNORE_DEPENDS and ALWAYS_BUILD_DEPENDS hacks to avoid messing with XFree86 are turned off. Since XFree86 version 4 includes some software that used to be separate ports, when XFREE86_VERSION=3 the following variables are provided: USE_DGS LIB_DEPENDS on x11/dgs USE_FREETYPE LIB_DEPENDS on print/freetype USE_MESA LIB_DEPENDS on graphics/Mesa3 USE_XPM LIB_DEPENDS on graphics/xpm When XFREE86_VERSION=4, these variables have no effect. The LIB_DEPENDS in the tree for the above four ports have all been converted to the USE_* counterparts. For your information, this is the count of the number of ports: USE_DGS 0 USE_FREETYPE 16 USE_MESA 36 USE_XPM 236 There is a new variable, XAWVER, which is set to 6 when XFREE86_VERSION=3 and 7 when XFREE86_VERSION=4. This is also passed to PLIST_SUB so ports that build Xaw based shared libraries can use this variable to substitute the shlib version number. There is also a provision of using a separate mtree file for XFREE86_VERSION=4, but that part is not enabled yet. Reviewed by: the ports list Tested by: make index (XFREE86_VERSION=3 only) (2) Add hebrew to list of valid categories. Submitted by: nbm
Notes
Notes: svn path=/head/; revision=31272
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk41
1 files changed, 37 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 4d525f3abb34..cd3930385bfd 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -754,7 +754,29 @@ BUILD_DEPENDS+= ${X11BASE}/lib/libXm.a:${PORTSDIR}/x11-toolkits/Motif-dummy
.endif
.endif
-PKG_IGNORE_DEPENDS?= '(XFree86-3\.3\.6|Motif-2\.1\.10)'
+# defaults to 3.3.6; will be changed to 4.0 when it is ready
+XFREE86_VERSION?= 3
+
+.if ${XFREE86_VERSION} == 3
+.if defined(USE_XPM)
+LIB_DEPENDS+= Xpm.4:${PORTSDIR}/graphics/xpm
+.endif
+.if defined(USE_DGS)
+LIB_DEPENDS+= dps.0:${PORTSDIR}/x11/dgs
+.endif
+.if defined(USE_MESA)
+LIB_DEPENDS+= GL.14:${PORTSDIR}/graphics/Mesa3
+.endif
+.if defined(USE_FREETYPE)
+LIB_DEPENDS+= ttf.4:${PORTSDIR}/print/freetype
+.endif
+XAWVER= 7
+PKG_IGNORE_DEPENDS?= '(XFree86-3\.3\.6|Motif-2\.1\.10)'
+.else
+XAWVER= 6
+PKG_IGNORE_DEPENDS?= 'Motif-2\.1\.10'
+.endif
+PLIST_SUB+= XAWVER=${XAWVER}
.if defined(USE_BISON)
.if ${OSVERSION} >= 400014
@@ -797,11 +819,17 @@ RUN_DEPENDS+= perl${PERL_VERSION}:${PORTSDIR}/lang/perl5
.endif
.endif
-# Don't try to build XFree86 even if ALWAYS_BUILD_DEPENDS is defined --
+.if defined(USE_XLIB)
+.if ${XFREE86_VERSION} == 3
+# Don't try to build XFree86-3 even if ALWAYS_BUILD_DEPENDS is defined --
# it's just too big....
-.if defined(USE_XLIB) && !defined(ALWAYS_BUILD_DEPENDS)
+.if !defined(ALWAYS_BUILD_DEPENDS)
LIB_DEPENDS+= X11.6:${PORTSDIR}/x11/XFree86
.endif
+.else
+LIB_DEPENDS+= X11.6:${PORTSDIR}/x11/XFree86-4-libraries
+.endif
+.endif
.if exists(${PORTSDIR}/../Makefile.inc)
.include "${PORTSDIR}/../Makefile.inc"
@@ -905,8 +933,13 @@ EXTRACT_CMD?= ${GZIP_CMD}
# Figure out where the local mtree file is
.if !defined(MTREE_FILE) && !defined(NO_MTREE)
.if defined(USE_X_PREFIX)
+.if ${XFREE86_VERSION} == 3
MTREE_FILE= /etc/mtree/BSD.x11.dist
.else
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+#MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+.else
MTREE_FILE= /etc/mtree/BSD.local.dist
.endif
.endif
@@ -1135,7 +1168,7 @@ maintainer:
VALID_CATEGORIES+= afterstep archivers astro audio benchmarks biology \
cad chinese comms converters databases deskutils devel \
editors elisp emulators ftp games german gnome graphics \
- ipv6 irc japanese java kde korean lang linux \
+ hebrew ipv6 irc japanese java kde korean lang linux \
mail math mbone misc net news \
offix palm perl5 plan9 print python russian \
security shells sysutils \