aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-09-08 14:13:01 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-09-08 14:13:01 +0000
commitcd9e609ae08f092b494bcd68508ec77c6a88c02b (patch)
treec60b4c927f9b8046b70541431e7c026103a9c561 /Mk
parentf999dd783a857334b6b800fa2cf0567fc6d97b83 (diff)
downloadports-cd9e609ae08f092b494bcd68508ec77c6a88c02b.tar.gz
ports-cd9e609ae08f092b494bcd68508ec77c6a88c02b.zip
Allow adding only a build or run-time dependency on USES=ssl.
PR: 202175 Reported by: barnerd Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=421556
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/ssl.mk19
1 files changed, 16 insertions, 3 deletions
diff --git a/Mk/Uses/ssl.mk b/Mk/Uses/ssl.mk
index cad798ec409c..24005d0086e2 100644
--- a/Mk/Uses/ssl.mk
+++ b/Mk/Uses/ssl.mk
@@ -4,7 +4,7 @@
#
# Feature: SSL_DEFAULT
# Usage: USES=ssl
-# Valid ARGS: none
+# Valid ARGS: none (build and run), build, run
#
# The user can choose which ssl library he wants with:
#
@@ -28,8 +28,17 @@
.if !defined(_INCLUDE_USES_SSL_MK)
_INCLUDE_USES_SSL_MK= yes
-.if !empty(ssl_ARGS)
-IGNORE= "USES=ssl does not take any argument."
+.if !empty(ssl_ARGS:Nbuild:Nrun)
+IGNORE= "USES=ssl invalid arguments ${ssl_ARGS}."
+.endif
+
+.if empty(ssl_ARGS) || (!empty(ssl_ARGS:Mbuild) && !empty(ssl_ARGS:Mrun))
+_SSL_BUILD_DEP= 1
+_SSL_RUN_DEP= 1
+.elif !empty(ssl_ARGS:Mbuild)
+_SSL_BUILD_DEP= 1
+.elif !empty(ssl_ARGS:Mrun)
+_SSL_RUN_DEP= 1
.endif
.if ${SSL_DEFAULT} == base
@@ -87,8 +96,12 @@ OPENSSL_PORT= security/${SSL_DEFAULT}
. endif
OPENSSLDIR?= ${OPENSSLBASE}/openssl
+.if defined(_SSL_BUILD_DEP)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcrypto.so.${OPENSSL_SHLIBVER}:${OPENSSL_PORT}
+.endif
+.if defined(_SSL_RUN_DEP)
RUN_DEPENDS+= ${LOCALBASE}/lib/libcrypto.so.${OPENSSL_SHLIBVER}:${OPENSSL_PORT}
+.endif
OPENSSLRPATH= ${LOCALBASE}/lib
.endif