aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-06-14 13:00:48 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-06-14 13:00:48 +0000
commitd48e842cfa3b004fdb71fb14f3a8d3cb56b69eb4 (patch)
tree572d171b74e9c3be81224881587b9d65907ed853 /Mk
parentbdace5957e15a974291e75b967f21e6adea1a18f (diff)
downloadports-d48e842cfa3b004fdb71fb14f3a8d3cb56b69eb4.tar.gz
ports-d48e842cfa3b004fdb71fb14f3a8d3cb56b69eb4.zip
Sort PORT_OPTIONS only once and remove some undefines.
Approved by: bapt
Notes
Notes: svn path=/head/; revision=320909
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.options.mk23
1 files changed, 6 insertions, 17 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 36c5be8ba8e4..9e11c8f27a33 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -120,10 +120,7 @@ PORT_OPTIONS:= ${OPTIONS_OVERRIDE}
NEW_OPTIONS= ${COMPLETE_OPTIONS_LIST}
## Set default options defined by the port maintainer
-. for opt in ${OPTIONS_DEFAULT}
-PORT_OPTIONS+= ${opt}
-. endfor
-PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
+PORT_OPTIONS+= ${OPTIONS_DEFAULT}
## Set system-wide defined options (set by user in make.conf)
. for opt in ${OPTIONS_SET}
@@ -132,7 +129,6 @@ PORT_OPTIONS+= ${opt}
NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
. endif
. endfor
-PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
## Remove the options excluded system-wide (set by user in make.conf)
. for opt in ${OPTIONS_UNSET}
@@ -147,7 +143,6 @@ PORT_OPTIONS+= ${opt}
NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
. endif
. endfor
-PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
## Unset the options excluded per-port (set by user in make.conf)
. for opt in ${${UNIQUENAME}_UNSET}
@@ -167,7 +162,6 @@ NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
.for opt in ${ALL_OPTIONS}
.if defined(WITH_${opt})
PORT_OPTIONS+= ${opt}
-PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
.endif
.if defined(WITHOUT_${opt})
PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
@@ -181,13 +175,11 @@ PORT_OPTIONS+= ${opt}
NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
. endif
. endfor
-PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
.for opt in ${OPTIONS_FILE_UNSET}
PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
.endfor
-.undef opt
.endif
@@ -199,7 +191,6 @@ PORT_OPTIONS+= ${opt}
NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
. endif
. endfor
-PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
## Remove the options excluded system-wide (set by user in make.conf)
. for opt in ${OPTIONS_UNSET_FORCE}
@@ -214,7 +205,6 @@ PORT_OPTIONS+= ${opt}
NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
. endif
. endfor
-PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
## Unset the options excluded per-port (set by user in make.conf)
. for opt in ${${UNIQUENAME}_UNSET_FORCE}
@@ -230,17 +220,17 @@ PORT_OPTIONS+= ${opt}
NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
. endif
.endfor
-PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
.for opt in ${WITHOUT}
PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
.endfor
-.for opt in ${OPTIONS_SLAVE}
-PORT_OPTIONS+= ${opt}
-.endfor
-.undef opt
+# Finally, add options required by slave ports
+PORT_OPTIONS+= ${OPTIONS_SLAVE}
+
+# Sort options and eliminate duplicates
+PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
## Now some compatibility
.if empty(PORT_OPTIONS:MDOCS)
@@ -270,7 +260,6 @@ WITHOUT_${opt}:= true
WITH_${opt}:= true
. endif
.endif
-. undef opt
.endfor
.endif
###