aboutsummaryrefslogtreecommitdiff
path: root/Tools
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-05-25 15:15:41 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-05-25 15:15:41 +0000
commit27ef913f54b56053c515815a8142531c9df75631 (patch)
tree0cb1d6a18fd88242ec5b36e295a9202d551b9b31 /Tools
parent1e2bb9d2d1c38f5d0f559ef9d393f95e7c895b23 (diff)
downloadports-27ef913f54b56053c515815a8142531c9df75631.tar.gz
ports-27ef913f54b56053c515815a8142531c9df75631.zip
Support PATCH_WRKSRC. See
http://people.freebsd.org/~trevor/ports/update-patches-1.411.diff for the accompanying patch to bsd.port.mk. PR: 24292
Notes
Notes: svn path=/head/; revision=59983
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/scripts/update-patches6
1 files changed, 3 insertions, 3 deletions
diff --git a/Tools/scripts/update-patches b/Tools/scripts/update-patches
index d5845a87fdc9..c53f0e30060c 100755
--- a/Tools/scripts/update-patches
+++ b/Tools/scripts/update-patches
@@ -26,7 +26,7 @@
# SUCH DAMAGE.
# Find out all .orig files and strip the name to what diff will use
-cd $WRKSRC && find . -type f -name '*.orig' | fgrep -v $DISTORIG | \
+cd $PATCH_WRKSRC && find . -type f -name '*.orig' | fgrep -v $DISTORIG | \
sed -e "s,^./\(.*\)\.orig\$,\1," | {
while read file
do
@@ -47,7 +47,7 @@ do
# found it, splice before diff part with diff
esc=`echo $file | sed -e 's,/,\\\\/,g'`
{ sed -e "/^--- $esc.orig/,\$ d" <$i
- (cd $WRKSRC && diff ${DIFF_ARGS} -u $file.orig $file) } >$i.new
+ (cd $PATCH_WRKSRC && diff ${DIFF_ARGS} -u $file.orig $file) } >$i.new
# did it change ? mark it as changed
if diff ${DIFF_ARGS} -u --ignore-matching-lines="^--- $file.orig .*" \
--ignore-matching-lines="^+++ $file .*" $i $i.new 1>&2
@@ -66,7 +66,7 @@ do
# Build a sensible name for the patch file
patchname=patch-`echo $file|sed -e s,/,_,g`
echo 1>&2 "No patch-* found for $file, creating $patchname"
- (cd $WRKSRC && diff -p ${DIFF_ARGS} -u $file.orig $file) >$patchname
+ (cd $PATCH_WRKSRC && diff -p ${DIFF_ARGS} -u $file.orig $file) >$patchname
edit="$edit $patchname"
accounted="$accounted $patchname"
done