aboutsummaryrefslogtreecommitdiff
path: root/accessibility/dasher
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-12 18:14:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-12 18:14:08 +0000
commit27a5844dee485179294cbfb4e2286e8f2375a760 (patch)
tree2813a530621a6dab955d09553dc6ad4709fb23e1 /accessibility/dasher
parent88138b7f28ec86642979293ff6100de9f65ff8c8 (diff)
downloadports-27a5844dee485179294cbfb4e2286e8f2375a760.tar.gz
ports-27a5844dee485179294cbfb4e2286e8f2375a760.zip
Fix a crash in dasher if there are no speech voices.
Reported by: Fernan Aguero <fernan@iib.unsam.edu.ar>
Notes
Notes: svn path=/head/; revision=121464
Diffstat (limited to 'accessibility/dasher')
-rw-r--r--accessibility/dasher/Makefile2
-rw-r--r--accessibility/dasher/files/patch-Src_Gtk2_speech.cc11
2 files changed, 12 insertions, 1 deletions
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index 43cc4b23de35..c3a0f72b82e1 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dasher
PORTVERSION= 3.2.11
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= accessibility editors x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/3.2
diff --git a/accessibility/dasher/files/patch-Src_Gtk2_speech.cc b/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
new file mode 100644
index 000000000000..e3ab155cbb88
--- /dev/null
+++ b/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
@@ -0,0 +1,11 @@
+--- Src/Gtk2/speech.cc.orig Fri Nov 12 13:11:45 2004
++++ Src/Gtk2/speech.cc Fri Nov 12 13:11:59 2004
+@@ -46,7 +46,7 @@
+
+ voices = GNOME_Speech_SynthesisDriver_getAllVoices (rv, &ev);
+
+- if (voices==NULL || BONOBO_EX (&ev)) {
++ if (voices==NULL || voices->_buffer==NULL || BONOBO_EX (&ev)) {
+ printf(_("Unable to initialize voices"));
+ speaker=NULL;
+ return;