aboutsummaryrefslogtreecommitdiff
path: root/accessibility/dasher
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-03 08:17:19 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-03 08:17:19 +0000
commitb46f180628b97b639448f2ca8d4e27bd7aff4c73 (patch)
tree6b8ceae32c907b4d7dec5dfaea765ff2f88295d2 /accessibility/dasher
parentd1e81bc737009c4ab7822057eb530c7aa5cc4e44 (diff)
downloadports-b46f180628b97b639448f2ca8d4e27bd7aff4c73.tar.gz
ports-b46f180628b97b639448f2ca8d4e27bd7aff4c73.zip
Merge diffs from my GNOME 2.5 repo.
* Make this port build * Use USE_BZIP2 * Point to MASTER_SITE_GNOME * Correct pkg-plist * Obey CFLAGS * Use USE_LIBTOOL to avoid threading problems on -CURRENT * Add additional categories
Notes
Notes: svn path=/head/; revision=97190
Diffstat (limited to 'accessibility/dasher')
-rw-r--r--accessibility/dasher/Makefile24
-rw-r--r--accessibility/dasher/distinfo2
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore-AlphabetMap.h10
-rw-r--r--accessibility/dasher/files/patch-configure10
-rw-r--r--accessibility/dasher/pkg-plist37
5 files changed, 67 insertions, 16 deletions
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index 6bb319273272..f0f8ca7cd2da 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -7,24 +7,28 @@
PORTNAME= dasher
PORTVERSION= 3.0.2
-CATEGORIES= editors
-MASTER_SITES= http://www.inference.phy.cam.ac.uk/${PORTNAME}/download/linux/source/3.0/
+PORTREVISION= 1
+CATEGORIES= editors x11 gnome accessibility
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/3.2
DIST_SUBDIR= gnome2
MAINTAINER= purple@lewiz.net
COMMENT= Information efficient text-entry interface
-LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
-
+USE_BZIP2= yes
USE_X_PREFIX= yes
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gtk2 --disable-gtkmmtest
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CFLAGS="-I${LOCALBASE}/include"
USE_GMAKE= yes
-
-LDFLAGS+= -L{LOCALBASE}/lib
+USE_GNOME= gnomeprefix gnomehack gnomehier gconf2 libglade2
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= dasher.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-O2||g'
+
.include <bsd.port.mk>
diff --git a/accessibility/dasher/distinfo b/accessibility/dasher/distinfo
index 9158185bfece..3a92dfe6f5a6 100644
--- a/accessibility/dasher/distinfo
+++ b/accessibility/dasher/distinfo
@@ -1 +1 @@
-MD5 (gnome2/dasher-3.0.2.tar.gz) = 1207d4076809fb69bb96ac11ce65bcd2
+MD5 (gnome2/dasher-3.2.1.tar.bz2) = de7850954023aa26276cbdf4cd4e2c8f
diff --git a/accessibility/dasher/files/patch-Src_DasherCore-AlphabetMap.h b/accessibility/dasher/files/patch-Src_DasherCore-AlphabetMap.h
new file mode 100644
index 000000000000..9931dd7aff60
--- /dev/null
+++ b/accessibility/dasher/files/patch-Src_DasherCore-AlphabetMap.h
@@ -0,0 +1,10 @@
+--- Src/DasherCore/AlphabetMap.h.orig Sun Dec 14 10:56:59 2003
++++ Src/DasherCore/AlphabetMap.h Sun Dec 14 10:57:30 2003
+@@ -50,6 +50,7 @@
+ #define __AlphabetMap_h__
+
+ #include "../Common/MSVC_Unannoy.h"
++#include <sys/types.h>
+ #include <vector>
+ #include <string>
+
diff --git a/accessibility/dasher/files/patch-configure b/accessibility/dasher/files/patch-configure
new file mode 100644
index 000000000000..f195f07b43c6
--- /dev/null
+++ b/accessibility/dasher/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Dec 11 18:31:51 2002
++++ configure Thu Dec 12 12:07:17 2002
+@@ -7414,6 +7414,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/accessibility/dasher/pkg-plist b/accessibility/dasher/pkg-plist
index 525ec9d3225a..8f5be7573224 100644
--- a/accessibility/dasher/pkg-plist
+++ b/accessibility/dasher/pkg-plist
@@ -1,6 +1,33 @@
bin/dasher
-share/dasher/alphabet.dtd
-share/dasher/alphabet.xml
-share/dasher/alphabet.xsl
-share/dasher/training_english_GB.txt
-@dirrm share/dasher
+share/gnome/applications/dasher.desktop
+share/gnome/dasher/alphabet.albanian.xml
+share/gnome/dasher/alphabet.dtd
+share/gnome/dasher/alphabet.dutch.xml
+share/gnome/dasher/alphabet.english.xml
+share/gnome/dasher/alphabet.french.xml
+share/gnome/dasher/alphabet.german.xml
+share/gnome/dasher/alphabet.hiragana.xml
+share/gnome/dasher/alphabet.hungarian.xml
+share/gnome/dasher/alphabet.hungarianLowerCase.xml
+share/gnome/dasher/alphabet.italian.xml
+share/gnome/dasher/alphabet.korean.xml
+share/gnome/dasher/alphabet.polish.xml
+share/gnome/dasher/alphabet.portuguese.xml
+share/gnome/dasher/alphabet.russian.xml
+share/gnome/dasher/alphabet.spanish.xml
+share/gnome/dasher/alphabet.xsl
+share/gnome/dasher/colour.dtd
+share/gnome/dasher/colour.hiragana.xml
+share/gnome/dasher/colour.xml
+share/gnome/dasher/dasher.glade
+share/gnome/dasher/training_dutch_NL.txt
+share/gnome/dasher/training_english_GB.txt
+share/gnome/dasher/training_french_FR.txt
+share/gnome/dasher/training_german_DE.txt
+share/gnome/dasher/training_hiragana60_JP.txt
+share/gnome/dasher/training_hiragana83_JP.txt
+share/gnome/dasher/training_italian_IT.txt
+share/gnome/dasher/training_portuguese_BR.txt
+share/gnome/icons/dasher.png
+share/locale/fr/LC_MESSAGES/dasher.mo
+@dirrm share/gnome/dasher