aboutsummaryrefslogtreecommitdiff
path: root/accessibility/orca/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-25 05:12:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-25 05:12:50 +0000
commit1f596f873d4a2024d3d248250f271d636bf7d32a (patch)
treee4d85033b560f95f7bf6dd6d52c113ea89fb0a47 /accessibility/orca/Makefile
parent78dee058040b6bd023ff29a0d88145977f98fc72 (diff)
downloadports-1f596f873d4a2024d3d248250f271d636bf7d32a.tar.gz
ports-1f596f873d4a2024d3d248250f271d636bf7d32a.zip
Fix orca so that it actually runs. While here, replace some hardcoded paths
with replaceable values.
Notes
Notes: svn path=/head/; revision=188239
Diffstat (limited to 'accessibility/orca/Makefile')
-rw-r--r--accessibility/orca/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/accessibility/orca/Makefile b/accessibility/orca/Makefile
index 3344b316898c..84dd8e2363f9 100644
--- a/accessibility/orca/Makefile
+++ b/accessibility/orca/Makefile
@@ -8,6 +8,7 @@
PORTNAME= orca
PORTVERSION= 2.18.0
+PORTREVISION= 1
CATEGORIES= accessibility x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -17,6 +18,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Scriptable screen reader
LIB_DEPENDS= gnome-mag.2:${PORTSDIR}/accessibility/gnome-mag
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
LATEST_LINK= gnome-orca
@@ -33,4 +35,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= orca.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
+ s|/usr/X11R6|${X11BASE}|g' \
+ ${WRKSRC}/src/orca/orca.in
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/src/orca/orca_i18n.py
+
.include <bsd.port.mk>