aboutsummaryrefslogtreecommitdiff
path: root/accessibility/speech-dispatcher/Makefile
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-01-08 08:24:00 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-01-08 08:24:00 +0000
commit863cef16416ef72f09fc7b9fa8095529e5f608ef (patch)
tree3c75e7af2f3d16a11f2c019074eb0d48eb14b13b /accessibility/speech-dispatcher/Makefile
parent10b9bb8657c9976a4a1f131aa137c549c938a667 (diff)
downloadports-863cef16416ef72f09fc7b9fa8095529e5f608ef.tar.gz
ports-863cef16416ef72f09fc7b9fa8095529e5f608ef.zip
- Add speech-dispatcher
Speech Dispatcher is a device independent layer for speech synthesis, developed with the goal of making the usage of speech synthesis easier for application programmers. It takes care of most of the tasks necessary to solve in speech enabled applications. What is a very high level GUI library to graphics, Speech Dispatcher is to speech synthesis. PR: 142436 Submitted by: Alberto Villa Tested by: myself Approved by: miwi, tabthorpe (mentors implicit)
Notes
Notes: svn path=/head/; revision=247382
Diffstat (limited to 'accessibility/speech-dispatcher/Makefile')
-rw-r--r--accessibility/speech-dispatcher/Makefile111
1 files changed, 111 insertions, 0 deletions
diff --git a/accessibility/speech-dispatcher/Makefile b/accessibility/speech-dispatcher/Makefile
new file mode 100644
index 000000000000..bb6fa63c0eeb
--- /dev/null
+++ b/accessibility/speech-dispatcher/Makefile
@@ -0,0 +1,111 @@
+# New ports collection makefile for: speech-dispatcher
+# Date created: 8 December 2009
+# Whom: Alberto Villa <villa.alberto@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= speech-dispatcher
+PORTVERSION= 0.6.7
+CATEGORIES= accessibility audio
+MASTER_SITES= http://www.freebsoft.org/pub/projects/speechd/
+
+MAINTAINER= villa.alberto@gmail.com
+COMMENT= Common interface to speech synthesis
+
+LIB_DEPENDS= dotconf.0:${PORTSDIR}/devel/dotconf
+
+USE_RC_SUBR= speechd
+USE_GNOME= glib20 pkgconfig
+MAKE_JOBS_SAFE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --without-ibmtts --without-alsa --without-ivona
+USE_GMAKE= yes
+CFLAGS+= -I${LOCALBASE}/include
+USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/${PORTNAME}
+
+CONFFILES= clients/emacs.conf clients/gnome-speech.conf \
+ modules/cicero.conf modules/dtk-generic.conf \
+ modules/epos-generic.conf modules/espeak-generic.conf \
+ modules/espeak-mbrola-generic.conf modules/espeak.conf \
+ modules/festival.conf modules/flite.conf modules/ibmtts.conf \
+ modules/ivona.conf modules/llia_phon-generic.conf \
+ modules/swift-generic.conf speechd.conf
+
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+
+INFO= spd-say ${PORTNAME}-cs ${PORTNAME} ssip
+
+OPTIONS= ESPEAK "eSpeak output module" on \
+ FESTIVAL "Festival output module" off \
+ NAS "Network Audio System support" off \
+ PULSEAUDIO "PulseAudio support" off
+
+# no *.so library installed to link to
+#FLITE "Festival Lite output module" off \
+
+.include <bsd.port.pre.mk>
+
+.ifndef(WITHOUT_ESPEAK)
+LIB_DEPENDS+= espeak.1:${PORTSDIR}/audio/espeak
+CONFIGURE_ARGS+= --with-espeak
+PLIST_SUB+= ESPEAK=""
+.else
+CONFIGURE_ARGS+= --without-espeak
+PLIST_SUB+= ESPEAK="@comment "
+.endif
+
+.ifdef(WITH_FESTIVAL)
+RUN_DEPENDS+= festival:${PORTSDIR}/audio/festival \
+ ${LOCALBASE}/share/festival/lib/${PORTNAME}.scm:${PORTSDIR}/audio/festival-freebsoft-utils
+.endif
+
+#.ifdef(WITH_FLITE)
+#BUILD_DEPENDS+= flite:${PORTSDIR}/audio/flite
+#RUN_DEPENDS+= flite:${PORTSDIR}/audio/flite
+#CONFIGURE_ARGS+= --with-flite
+#PLIST_SUB+= FLITE=""
+#.else
+CONFIGURE_ARGS+= --without-flite
+PLIST_SUB+= FLITE="@comment "
+#.endif
+
+.ifdef(WITH_NAS)
+LIB_DEPENDS+= audio.2:${PORTSDIR}/audio/nas
+CONFIGURE_ARGS+= --with-nas
+.else
+CONFIGURE_ARGS+= --without-nas
+.endif
+
+.ifdef(WITH_PULSEAUDIO)
+LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
+CONFIGURE_ARGS+= --with-pulseaudio
+.else
+CONFIGURE_ARGS+= --without-pulseaudio
+.endif
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/g' \
+ ${WRKSRC}/ltmain.sh
+ @${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/src/audio/Makefile.in \
+ ${WRKSRC}/src/c/api/Makefile.in \
+ ${WRKSRC}/src/c/clients/spdsend/Makefile.in \
+ ${WRKSRC}/src/modules/Makefile.in \
+ ${WRKSRC}/src/server/Makefile.in
+
+post-install:
+.for f in ${CONFFILES}
+ @if [ ! -f ${ETCDIR}/${f} ]; then \
+ ${CP} -p ${ETCDIR}/${f}.sample ${ETCDIR}/${f}; \
+ fi
+.endfor
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>