aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-04-21 20:51:20 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-04-22 07:25:13 +0000
commit1a3219fc0441a9e024c690cbd4c5b2a043c4add4 (patch)
treeec885dabd52d3539f22855540fe5085d2ac80954 /accessibility
parentcf2ddc27fb747c46256ccc3c0f1a5bd2413fe662 (diff)
downloadports-1a3219fc0441a9e024c690cbd4c5b2a043c4add4.tar.gz
ports-1a3219fc0441a9e024c690cbd4c5b2a043c4add4.zip
accessibility/qt5-speech: fix FLITE/ALSA options and config mixups
There is a complicated interplay between ALSA and FLITE in the qt5-speech port, and ALSA options in other parts of the Qt stack. This patch tries to offer enough knobs to manage the game. PR: 245614 Submitted by: tcberner Reported by: John Hein
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/qt5-speech/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/accessibility/qt5-speech/Makefile b/accessibility/qt5-speech/Makefile
index b1ae4892d427..b451bb6a9a75 100644
--- a/accessibility/qt5-speech/Makefile
+++ b/accessibility/qt5-speech/Makefile
@@ -1,5 +1,6 @@
PORTNAME= speech
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= accessibility
PKGNAMEPREFIX= qt5-
@@ -11,6 +12,7 @@ USES= compiler:c++11-lang gl pkgconfig qmake:outsource,norecursive \
USE_GL= gl
USE_QT= core gui buildtools_build qmake_build
+OPTIONS_DEFINE= ALSA
OPTIONS_MULTI= BACKEND
OPTIONS_MULTI_BACKEND= SPEECHD FLITE
OPTIONS_DEFAULT= SPEECHD
@@ -27,6 +29,11 @@ FLITE_DESC= Festival Lite Backend
FLITE_LIB_DEPENDS= libflite.so:audio/flite
FLITE_USE= QT=multimedia,network
FLITE_VARS= QMAKE_CONFIGURE_ARGS+=--feature-flite
-FLITE_VARS_OFF= QMAKE_CONFIGURE_ARGS+=--no-feature-flite
+FLITE_VARS_OFF= QMAKE_CONFIGURE_ARGS+=--no-feature-flite --no-feature-flite_alsa
+
+ALSA_IMPLIES= FLITE
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
+ALSA_VARS= QMAKE_CONFIGURE_ARGS+=--feature-flite_alsa
+ALSA_VARS_OFF= QMAKE_CONFIGURE_ARGS+=--no-feature-flite_alsa
.include <bsd.port.mk>