aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-10-12 18:55:54 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-10-12 18:55:54 +0000
commitb7ea89d0aff07f59bfef0b39191f3360b8fcd050 (patch)
tree8af3e5269688dbc650f93de57ce449c41a6bb0ef /accessibility
parente1225c446e4c6d360d8de4bee54c6c7333baeec2 (diff)
downloadports-b7ea89d0aff07f59bfef0b39191f3360b8fcd050.tar.gz
ports-b7ea89d0aff07f59bfef0b39191f3360b8fcd050.zip
accessibility/py3-speech-dispatcher: fix packaging with python 3.5
While here add NO_ARCH and make couple of whitespace fixes. PR: 213393 Approved by: portmgr (blanket approval)
Notes
Notes: svn path=/head/; revision=423881
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/py3-speech-dispatcher/Makefile6
-rw-r--r--accessibility/py3-speech-dispatcher/pkg-plist14
-rw-r--r--accessibility/speech-dispatcher/Makefile18
3 files changed, 24 insertions, 14 deletions
diff --git a/accessibility/py3-speech-dispatcher/Makefile b/accessibility/py3-speech-dispatcher/Makefile
index affb313ea68c..e2633ce8922c 100644
--- a/accessibility/py3-speech-dispatcher/Makefile
+++ b/accessibility/py3-speech-dispatcher/Makefile
@@ -1,16 +1,16 @@
# $FreeBSD$
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
COMMENT= Common interface to speech synthesis python bindings
SPEECH_SLAVE= yes
-MASTERDIR= ${.CURDIR}/../../accessibility/speech-dispatcher
+MASTERDIR= ${.CURDIR}/../speech-dispatcher
BUILD_WRKSRC= ${WRKSRC}/src/api/python
INSTALL_WRKSRC= ${WRKSRC}/src/api/python
-PLIST= ${.CURDIR}/pkg-plist
+PLIST= ${.CURDIR}/pkg-plist
.include "${MASTERDIR}/Makefile"
diff --git a/accessibility/py3-speech-dispatcher/pkg-plist b/accessibility/py3-speech-dispatcher/pkg-plist
index 3c6880c82559..8641af42baa3 100644
--- a/accessibility/py3-speech-dispatcher/pkg-plist
+++ b/accessibility/py3-speech-dispatcher/pkg-plist
@@ -1,23 +1,23 @@
bin/spd-conf
%%PYTHON_SITELIBDIR%%/speechd/__init__.py
%%PYTHON_SITELIBDIR%%/speechd/__pycache__/__init__.cpython-%%PYVER%%.pyc
-%%PYTHON_SITELIBDIR%%/speechd/__pycache__/__init__.cpython-%%PYVER%%.pyo
+%%PYTHON_SITELIBDIR%%/speechd/__pycache__/__init__.cpython-%%PYVER%%.%%PYOEXTENSION%%
%%PYTHON_SITELIBDIR%%/speechd/__pycache__/_test.cpython-%%PYVER%%.pyc
-%%PYTHON_SITELIBDIR%%/speechd/__pycache__/_test.cpython-%%PYVER%%.pyo
+%%PYTHON_SITELIBDIR%%/speechd/__pycache__/_test.cpython-%%PYVER%%.%%PYOEXTENSION%%
%%PYTHON_SITELIBDIR%%/speechd/__pycache__/client.cpython-%%PYVER%%.pyc
-%%PYTHON_SITELIBDIR%%/speechd/__pycache__/client.cpython-%%PYVER%%.pyo
+%%PYTHON_SITELIBDIR%%/speechd/__pycache__/client.cpython-%%PYVER%%.%%PYOEXTENSION%%
%%PYTHON_SITELIBDIR%%/speechd/__pycache__/paths.cpython-%%PYVER%%.pyc
-%%PYTHON_SITELIBDIR%%/speechd/__pycache__/paths.cpython-%%PYVER%%.pyo
+%%PYTHON_SITELIBDIR%%/speechd/__pycache__/paths.cpython-%%PYVER%%.%%PYOEXTENSION%%
%%PYTHON_SITELIBDIR%%/speechd/_test.py
%%PYTHON_SITELIBDIR%%/speechd/client.py
%%PYTHON_SITELIBDIR%%/speechd/paths.py
%%PYTHON_SITELIBDIR%%/speechd_config/__init__.py
%%PYTHON_SITELIBDIR%%/speechd_config/__pycache__/__init__.cpython-%%PYVER%%.pyc
-%%PYTHON_SITELIBDIR%%/speechd_config/__pycache__/__init__.cpython-%%PYVER%%.pyo
+%%PYTHON_SITELIBDIR%%/speechd_config/__pycache__/__init__.cpython-%%PYVER%%.%%PYOEXTENSION%%
%%PYTHON_SITELIBDIR%%/speechd_config/__pycache__/config.cpython-%%PYVER%%.pyc
-%%PYTHON_SITELIBDIR%%/speechd_config/__pycache__/config.cpython-%%PYVER%%.pyo
+%%PYTHON_SITELIBDIR%%/speechd_config/__pycache__/config.cpython-%%PYVER%%.%%PYOEXTENSION%%
%%PYTHON_SITELIBDIR%%/speechd_config/__pycache__/paths.cpython-%%PYVER%%.pyc
-%%PYTHON_SITELIBDIR%%/speechd_config/__pycache__/paths.cpython-%%PYVER%%.pyo
+%%PYTHON_SITELIBDIR%%/speechd_config/__pycache__/paths.cpython-%%PYVER%%.%%PYOEXTENSION%%
%%PYTHON_SITELIBDIR%%/speechd_config/config.py
%%PYTHON_SITELIBDIR%%/speechd_config/paths.py
share/sounds/speech-dispatcher/test.wav
diff --git a/accessibility/speech-dispatcher/Makefile b/accessibility/speech-dispatcher/Makefile
index c9056fde6368..58422f99c72a 100644
--- a/accessibility/speech-dispatcher/Makefile
+++ b/accessibility/speech-dispatcher/Makefile
@@ -68,6 +68,7 @@ NAS_CONFIGURE_WITH= nas
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_WITH=pulse
+.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e '/SUBDIRS/ s/tests//' \
${WRKSRC}/src/Makefile.in
@@ -84,13 +85,22 @@ post-install:
.else
-USES+= python:3
+NO_ARCH= yes
+USES+= python:3.3+
LIB_DEPENDS+= libspeechd.so:accessibility/speech-dispatcher
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/xdg/__init__.py:devel/py3-xdg
-USE_PYTHON= py3kplist
-PLIST_SUB= PYVER=${PYTHON_VER:S|.||}
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+PYOEXTENSION= pyo
+.else
+PYOEXTENSION= opt-1.pyc
+.endif
+
+PLIST_SUB+= PYOEXTENSION=${PYOEXTENSION} \
+ PYVER=${PYTHON_VER:S/.//}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>