aboutsummaryrefslogtreecommitdiff
path: root/accessibility
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-10-10 11:59:15 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-10-10 11:59:15 +0000
commitb7fe8f6183be351606b3790241bc9acb7ee9ad11 (patch)
treed67cea2bf1219730e712c827dfb239dcdcb495c2 /accessibility
parent66af45fe755d348c2feb127c89c4743319453425 (diff)
downloadports-b7fe8f6183be351606b3790241bc9acb7ee9ad11.tar.gz
ports-b7fe8f6183be351606b3790241bc9acb7ee9ad11.zip
Catchup with recent developers warnings
Notes
Notes: svn path=/head/; revision=514220
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/accerciser/Makefile2
-rw-r--r--accessibility/at-spi2-core/Makefile2
-rw-r--r--accessibility/atkmm/Makefile2
-rw-r--r--accessibility/caribou/Makefile4
-rw-r--r--accessibility/kmousetool/Makefile2
-rw-r--r--accessibility/py-papi/Makefile2
-rw-r--r--accessibility/qt5-speech/Makefile3
-rw-r--r--accessibility/redshift/Makefile4
-rw-r--r--accessibility/sct/Makefile1
9 files changed, 12 insertions, 10 deletions
diff --git a/accessibility/accerciser/Makefile b/accessibility/accerciser/Makefile
index e453262a822a..c738f69a5402 100644
--- a/accessibility/accerciser/Makefile
+++ b/accessibility/accerciser/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= gsettings-desktop-schemas>=3.2.0:devel/gsettings-desktop-schemas \
at-spi2-core>=2.1.5:accessibility/at-spi2-core
NO_ARCH= yes
-USES= gettext gmake localbase:ldflags pkgconfig python:3.4+ shebangfix tar:xz
+USES= gettext gmake gnome localbase:ldflags pkgconfig python:3.4+ shebangfix tar:xz
USE_GNOME= gtk30 intlhack pygobject3
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/accessibility/at-spi2-core/Makefile b/accessibility/at-spi2-core/Makefile
index 2715d82063d6..d3a0f9a07d38 100644
--- a/accessibility/at-spi2-core/Makefile
+++ b/accessibility/at-spi2-core/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
PORTSCOUT= limitw:1,even
-USES= gettext gnome localbase meson pkgconfig tar:xz
+USES= gettext gnome localbase meson pkgconfig tar:xz xorg
USE_GNOME= glib20 introspection:build
USE_XORG= ice sm x11 xi xtst xext
USE_LDCONFIG= yes
diff --git a/accessibility/atkmm/Makefile b/accessibility/atkmm/Makefile
index d098bece4ef2..62d2f06701cb 100644
--- a/accessibility/atkmm/Makefile
+++ b/accessibility/atkmm/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
PORTSCOUT= limitw:1,even
-USES= compiler:c++11-lang gmake localbase libtool pathfix \
+USES= compiler:c++11-lang gmake gnome localbase libtool pathfix \
pkgconfig tar:xz
USE_GNOME= atk glibmm
USE_LDCONFIG= yes
diff --git a/accessibility/caribou/Makefile b/accessibility/caribou/Makefile
index df8fab27bd1c..33d86dc350a9 100644
--- a/accessibility/caribou/Makefile
+++ b/accessibility/caribou/Makefile
@@ -23,8 +23,8 @@ LIB_DEPENDS= libclutter-glx-1.0.so:graphics/clutter \
libdbus-1.so:devel/dbus
RUN_DEPENDS= py3?-atspi>=2.1.91:accessibility/py-atspi@${PY_FLAVOR}
-USES= gettext gmake gnome libtool localbase pathfix \
- pkgconfig python:3.3+ shebangfix tar:xz
+USES= gettext gl gmake gnome libtool localbase pathfix \
+ pkgconfig python:3.3+ shebangfix tar:xz xorg
USE_GNOME= cairo gdkpixbuf2 gtk30 intlhack introspection:build libxml2 \
libxslt:build pygobject3
USE_PYTHON= py3kplist
diff --git a/accessibility/kmousetool/Makefile b/accessibility/kmousetool/Makefile
index 205a4e5b4731..fe6ccf96d758 100644
--- a/accessibility/kmousetool/Makefile
+++ b/accessibility/kmousetool/Makefile
@@ -10,7 +10,7 @@ COMMENT= Automatic mouse click tool for KDE
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz xorg
USE_KDE= auth codecs config configwidgets coreaddons dbusaddons \
ecm i18n iconthemes notifications widgetsaddons xmlgui
USE_QT= core dbus gui phonon4 widgets xml \
diff --git a/accessibility/py-papi/Makefile b/accessibility/py-papi/Makefile
index c1dfe70dff44..22d56f74e845 100644
--- a/accessibility/py-papi/Makefile
+++ b/accessibility/py-papi/Makefile
@@ -14,7 +14,7 @@ COMMENT= ATK accessibility wrapper for python
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pkgconfig python:2.7
+USES= gnome pkgconfig python:2.7
USE_GNOME= atk
USE_PYTHON= autoplist distutils
diff --git a/accessibility/qt5-speech/Makefile b/accessibility/qt5-speech/Makefile
index 9fdc0da3b46b..f200b9630536 100644
--- a/accessibility/qt5-speech/Makefile
+++ b/accessibility/qt5-speech/Makefile
@@ -8,7 +8,8 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Accessibilty features for Qt5
-USES= compiler:c++11-lang gl pkgconfig qmake:outsource qt-dist:5,speech
+USES= compiler:c++11-lang gl pkgconfig qmake:outsource \
+ qt-dist:5,speech xorg
USE_GL= gl
USE_QT= core gui buildtools_build qmake_build
diff --git a/accessibility/redshift/Makefile b/accessibility/redshift/Makefile
index 54640f3acd12..ee98d418aaf1 100644
--- a/accessibility/redshift/Makefile
+++ b/accessibility/redshift/Makefile
@@ -14,8 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libdrm.so:graphics/libdrm
-USES= autoreconf:build gettext gmake libtool localbase pkgconfig \
- shebangfix tar:bzip2
+USES= autoreconf:build gettext gmake gnome libtool localbase \
+ pkgconfig shebangfix tar:bzip2 xorg
USE_GITHUB= yes
GH_ACCOUNT= jonls
diff --git a/accessibility/sct/Makefile b/accessibility/sct/Makefile
index 5c4788462012..1bc005ca2938 100644
--- a/accessibility/sct/Makefile
+++ b/accessibility/sct/Makefile
@@ -10,6 +10,7 @@ COMMENT= Utility to change screen temperature
LICENSE= UNLICENSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+USES= xorg
USE_GITHUB= yes
GH_ACCOUNT= 0mp
USE_XORG= x11 xrandr