aboutsummaryrefslogtreecommitdiff
path: root/arabic
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-02 08:24:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-02 08:24:51 +0000
commit5320cf9a488396563699040fe89eb01253854b0a (patch)
tree29bef61c0f3b7c362f891002d35957c1190bee8b /arabic
parentb30f22964e9f5e2c297d0a4c95a1d71aa2b8bf68 (diff)
downloadports-5320cf9a488396563699040fe89eb01253854b0a.tar.gz
ports-5320cf9a488396563699040fe89eb01253854b0a.zip
- Rework broken conversion to option helpers in r399610: while ARABTEXDIRS
ends up with the correct values, .for loop in `do-install' recipe would not iterate over `doc' subdirectory. So instead, get rid of ARABTEXDIRS altogether and install docs in dedicated `do-install-DOCS-on' target - While here, optimize away MKTEXLSR variable that was used only to amend PLIST_SUB knob and convert EXTRACT_SUFX to USES=tar:tgz per portlint(1) Reported by: marino
Notes
Notes: svn path=/head/; revision=400639
Diffstat (limited to 'arabic')
-rw-r--r--arabic/arabtex/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/arabic/arabtex/Makefile b/arabic/arabtex/Makefile
index daabea9bba05..d23c52a74f71 100644
--- a/arabic/arabtex/Makefile
+++ b/arabic/arabtex/Makefile
@@ -7,32 +7,28 @@ PORTREVISION= 5
CATEGORIES= arabic print
MASTER_SITES= ftp://ftp.informatik.uni-stuttgart.de/pub/${PORTNAME}/
DISTNAME= arab${PORTVERSION:S/.//}
-EXTRACT_SUFX= .tgz
MAINTAINER= nivit@FreeBSD.org
COMMENT= TeX/LaTeX package to generate Arabic writing
LICENSE= LPPL10
+USES= tar:tgz
USE_TEX= base texmf
NO_WRKSUBDIR= yes
NO_BUILD= yes
-ARABTEXDIRS= fonts tex
-MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
-
-PLIST_SUB= MKTEXLSR=${MKTEXLSR}
+PLIST_SUB= MKTEXLSR=${LOCALBASE}/bin/mktexlsr
OPTIONS_DEFINE= DOCS
-DOCS_VARS= ARABTEXDIRS+=doc
-
do-install:
-.for dir in ${ARABTEXDIRS}
- @${MKDIR} ${STAGEDIR}${PREFIX}/${TEXMFLOCALDIR}/${dir}
- (cd ${WRKDIR}/${dir} && \
- ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${TEXMFLOCALDIR}/${dir})
-.endfor
+ (cd ${WRKDIR} && ${COPYTREE_SHARE} "fonts tex" \
+ ${STAGEDIR}${PREFIX}/${TEXMFLOCALDIR})
+
+do-install-DOCS-on:
+ (cd ${WRKDIR} && ${COPYTREE_SHARE} doc \
+ ${STAGEDIR}${PREFIX}/${TEXMFLOCALDIR})
.include <bsd.port.mk>