aboutsummaryrefslogtreecommitdiff
path: root/archivers/Makefile
diff options
context:
space:
mode:
authorJesús Daniel Colmenares Oviedo <DtxdF@disroot.org>2023-04-10 23:33:30 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-04-30 18:41:44 +0000
commit4dc6444322ea7e531a3c2bfbc87911295daff4ec (patch)
tree2b9cf7933a215f0faa7b2e0e1a05d382de6c9067 /archivers/Makefile
parent0b23819f46828089194537e0a085e9c8163c0cc5 (diff)
downloadports-4dc6444322ea7e531a3c2bfbc87911295daff4ec.tar.gz
ports-4dc6444322ea7e531a3c2bfbc87911295daff4ec.zip
archivers/py-zipstream-ng: New port: streamable zip file generator
zipstream-ng is a modern and easy to use streamable zip file generator. It can package and stream many files and folders on the fly without needing temporary files or excessive memory. Includes the ability to calculate the total size of the stream before any data is actually added (provided no compression is used). This makes it ideal for use in web applications since the total size can be used to set the `Content-Length` header without having to generate the entire file first. Features: * Generates zip data on the fly as it's requested. * Can calculate the total size of the resulting zip file before generation even begins. * Flexible API: Typical use cases are simple, complicated ones are possible. * Supports zipping data from files, bytes, strings, and any other iterable objects. * Threadsafe: Won't mangle data if multiple threads concurrently add/read data to/from the same stream. * Includes a clone of Python's `http.server` module with zip support added. Try `python -m zipstream.server`. * Automatically uses Zip64 extensions, but only if they are required. * No external dependencies. WWW: https://github.com/pR0Ps/zipstream-ng/ PR: 270750
Diffstat (limited to 'archivers/Makefile')
-rw-r--r--archivers/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 681b33f78d51..f76683b042aa 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -204,6 +204,7 @@
SUBDIR += py-sozipfile
SUBDIR += py-warctools
SUBDIR += py-xopen
+ SUBDIR += py-zipstream-ng
SUBDIR += py-zopfli
SUBDIR += py-zstandard
SUBDIR += py-zstd