aboutsummaryrefslogtreecommitdiff
path: root/archivers/ark/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
commit568f8e877fb50618d4813b943d712e3bc08fd147 (patch)
tree16eef3a555a802ca06d05606c7f2a75ccbc6a431 /archivers/ark/Makefile
parentbdcf355d6dedb8678255a8053a2b423f9cc7cc6c (diff)
downloadports-568f8e877fb50618d4813b943d712e3bc08fd147.tar.gz
ports-568f8e877fb50618d4813b943d712e3bc08fd147.zip
The KDE FreeBSD team is proud to announce the release of KDE 4.1.0
for FreeBSD. The official KDE 4.1.0 release notes can be found at http://www.kde.org/announcements/4.1/. Some note: * Prefix KDE4 will be install into a custom prefixes namely ${LOCALBASE}/kde4. KDE4 and KDE3 can co-exist * Sound For sound to work, it is necessary to have dbus and hal enabled in your system. Please see the respective documentation on how to enable these. For more Informations see the HEADS UP at ports@ and kde-freebsd@ or our wiki page http://wiki.freebsd.org/KDE4/Install. Have fun!
Notes
Notes: svn path=/head/; revision=218272
Diffstat (limited to 'archivers/ark/Makefile')
-rw-r--r--archivers/ark/Makefile60
1 files changed, 22 insertions, 38 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index ea718ae2ec7a..62ce2227f6ce 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -1,50 +1,34 @@
-# New ports collection makefile for: kdeutils3
-# Date created: 3 November 2001
-# Whom: will@cvs.kde.org
+# New ports collection Makefile for: kdeutils
+# Date created: 2008-01-31
+# Whom: Martin Wilke <miwi@FreeBSD.org>
#
# $FreeBSD$
-#
PORTNAME= kdeutils
-PORTVERSION= ${KDE_VERSION}
-CATEGORIES?= misc kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= misc kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
DIST_SUBDIR= KDE
-MAINTAINER?= kde@FreeBSD.org
-COMMENT= Utilities for the KDE integrated X11 desktop
-
-LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- netsnmp:${PORTSDIR}/net-mgmt/net-snmp
-RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Utilities for the KDE4 integrated X11 Desktop
-CONFLICTS= kgpg-[0-9]* superkaramba-[0-9]*
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
+ netsnmp:${PORTSDIR}/net-mgmt/net-snmp \
+ qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
+ zip.1:${PORTSDIR}/archivers/libzip
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
-USE_KDELIBS_VER=3
-USE_KDEBASE_VER=3
-PREFIX= ${KDE_PREFIX}
+LATEST_LINK= ${PORTNAME}4
-USE_PYTHON= yes
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
-DO_NOT_COMPILE+=klaptopdaemon kmilo
-CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
-CONFIGURE_ARGS+=--with-pythondir=${LOCALBASE}
-
-USE_LDCONFIG= yes
-LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.pre.mk>
+USE_QT_VER= 4
+KDE4_BUILDENV= yes
+USE_KDE4= kdelibs pimlibs workspace kdeprefix kdehier automoc4
+QT_COMPONENTS= network gui moc rcc uic porting xml
-.if ${OSVERSION} > 501102
-. if ${OSVERSION} > 600021
-RUN_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
-. endif
-post-patch:
- ${REINPLACE_CMD} -e 's|>tar<|>gtar<|g' ${WRKSRC}/ark/ark.kcfg
-.endif
+post-extract:
+ ${MKDIR} ${WRKSRC}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>