aboutsummaryrefslogtreecommitdiff
path: root/archivers/dpkg
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-04-19 00:49:48 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-04-19 00:49:48 +0000
commitdd0de43921c7d6f0f89cc59c24398cdab71ed545 (patch)
treea7e578f94f7da90682fb1d43966d4e5d3cee5231 /archivers/dpkg
parentc57799cb9d171d71f4dd6b4d8b085b41f30742aa (diff)
downloadports-dd0de43921c7d6f0f89cc59c24398cdab71ed545.tar.gz
ports-dd0de43921c7d6f0f89cc59c24398cdab71ed545.zip
- Fix shebang issues [1]
- Properly install and cleanup man dirs not in BSD.local.dist PR: ports/188755 [1] Submitted by: xmj [1]
Notes
Notes: svn path=/head/; revision=351578
Diffstat (limited to 'archivers/dpkg')
-rw-r--r--archivers/dpkg/Makefile5
-rw-r--r--archivers/dpkg/pkg-plist28
2 files changed, 32 insertions, 1 deletions
diff --git a/archivers/dpkg/Makefile b/archivers/dpkg/Makefile
index 09c6c45313a9..b93deeb94e60 100644
--- a/archivers/dpkg/Makefile
+++ b/archivers/dpkg/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dpkg
PORTVERSION= 1.17.6
+PORTREVISION= 1
CATEGORIES= archivers sysutils
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= dpkg_${PORTVERSION}
@@ -18,8 +19,10 @@ RUN_DEPENDS= gtar:${PORTSDIR}/archivers/gtar \
gmd5sum:${PORTSDIR}/sysutils/coreutils
GNU_CONFIGURE= yes
-USES= gmake iconv perl5 pkgconfig tar:xz
+USES= gmake iconv perl5 pkgconfig tar:xz shebangfix
WRKSRC= ${WRKDIR}/dpkg-${PORTVERSION}
+SHEBANG_FILES= dselect/methods/ftp/update dselect/methods/ftp/install \
+ dselect/methods/ftp/setup
DPKGDIR?= /var/db/dpkg
PLIST_SUB+= DPKGDIR=${DPKGDIR:C,^/,,}
diff --git a/archivers/dpkg/pkg-plist b/archivers/dpkg/pkg-plist
index 7dfc40c99e1b..629af2af0756 100644
--- a/archivers/dpkg/pkg-plist
+++ b/archivers/dpkg/pkg-plist
@@ -635,6 +635,34 @@ sbin/start-stop-daemon
@dirrmtry etc/dpkg/dpkg.cfg.d
@dirrmtry etc/dpkg
@dirrmtry etc/alternatives
+%%NLS%%@dirrmtry man/sv/man8
+%%NLS%%@dirrmtry man/sv/man5
+%%NLS%%@dirrmtry man/sv/man1
+%%NLS%%@dirrmtry man/sv
+%%NLS%%@dirrmtry man/pl/man8
+%%NLS%%@dirrmtry man/pl/man5
+%%NLS%%@dirrmtry man/pl/man1
+%%NLS%%@dirrmtry man/pl
+%%NLS%%@dirrmtry man/it/man8
+%%NLS%%@dirrmtry man/it/man5
+%%NLS%%@dirrmtry man/it/man1
+%%NLS%%@dirrmtry man/it
+%%NLS%%@dirrmtry man/hu/man8
+%%NLS%%@dirrmtry man/hu/man5
+%%NLS%%@dirrmtry man/hu/man1
+%%NLS%%@dirrmtry man/hu
+%%NLS%%@dirrmtry man/fr/man8
+%%NLS%%@dirrmtry man/fr/man5
+%%NLS%%@dirrmtry man/fr/man1
+%%NLS%%@dirrmtry man/fr
+%%NLS%%@dirrmtry man/es/man8
+%%NLS%%@dirrmtry man/es/man5
+%%NLS%%@dirrmtry man/es/man1
+%%NLS%%@dirrmtry man/es
+%%NLS%%@dirrmtry man/de/man8
+%%NLS%%@dirrmtry man/de/man5
+%%NLS%%@dirrmtry man/de/man1
+%%NLS%%@dirrmtry man/de
@cwd /
@exec mkdir -p %%DPKGDIR%%/alternatives
@exec mkdir -p %%DPKGDIR%%/info