aboutsummaryrefslogtreecommitdiff
path: root/archivers/file-roller/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-11-11 21:33:59 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-11-11 21:33:59 +0000
commit7f57e48d2d99b184dc3141db608cdf28401ccc3a (patch)
treebbf786a7b5f084ac4404488118186e96cbd74f52 /archivers/file-roller/Makefile
parente860fb7e3fce063275d81b81ebc3ba37d0b41977 (diff)
downloadports-7f57e48d2d99b184dc3141db608cdf28401ccc3a.tar.gz
ports-7f57e48d2d99b184dc3141db608cdf28401ccc3a.zip
Update file-roller to 3.28.1.
* Add options for additional archive types [1] Submitted by: Alexandre C. GuimarĂ£es <lebarondemerde@privacychain.ch> [1]
Notes
Notes: svn path=/head/; revision=484773
Diffstat (limited to 'archivers/file-roller/Makefile')
-rw-r--r--archivers/file-roller/Makefile25
1 files changed, 23 insertions, 2 deletions
diff --git a/archivers/file-roller/Makefile b/archivers/file-roller/Makefile
index 74ad94c6dc47..d920810c731c 100644
--- a/archivers/file-roller/Makefile
+++ b/archivers/file-roller/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= file-roller
-PORTVERSION= 3.28.0
+PORTVERSION= 3.28.1
PORTEPOCH= 1
CATEGORIES= archivers gnome
MASTER_SITES= GNOME
@@ -21,7 +21,7 @@ RUN_DEPENDS= gtar:archivers/gtar
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext libarchive localbase \
+USES= desktop-file-utils gettext gnome libarchive localbase \
meson pkgconfig python:3.5+,build tar:xz
USE_GNOME= cairo gtk30
INSTALLS_ICONS= yes
@@ -35,6 +35,27 @@ OPTIONS_SUB= yes
OPTIONS_DEFINE= NAUTILUS
OPTIONS_DEFAULT=NAUTILUS
+OPTIONS_GROUP= FORMATS
+OPTIONS_GROUP_FORMATS= 7ZIP ARJ LZO RAR ZIP
+
+FORMATS_DESC= Additional compression formats support
+
+7ZIP_DESC= 7zip archive support
+7ZIP_RUN_DEPENDS= 7z:archivers/p7zip
+
+ARJ_DESC= ARJ archive support
+ARJ_RUN_DEPENDS= arj:archivers/arj
+
+LZO_DESC= LZO compression support
+LZO_RUN_DEPENDS= lzop:archivers/lzop
+
+RAR_DESC= RAR archive support
+RAR_RUN_DEPENDS= rar:archivers/rar \
+ unrar:archivers/unrar
+
+ZIP_DESC= ZIP archive support
+ZIP_RUN_DEPENDS= zip:archivers/zip
+
NAUTILUS_DESC= Nautilus context menu actions
NAUTILUS_USE= GNOME=nautilus3
NAUTILUS_MESON_TRUE= nautilus-actions