aboutsummaryrefslogtreecommitdiff
path: root/archivers/libarchive/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-08-23 16:37:49 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-08-23 16:37:49 +0000
commit590901094aa68cba5749763688ba22d6f4653c82 (patch)
treecc89938835462170e4a3db4a50f1d665a340fd49 /archivers/libarchive/Makefile
parent508c5aacefa9cf422f0245547a4a31b6991ec655 (diff)
downloadports-590901094aa68cba5749763688ba22d6f4653c82.tar.gz
ports-590901094aa68cba5749763688ba22d6f4653c82.zip
. Update to 1.01.013.
. Fix a whitespace bogon. [2] Submitted by: portlint [2]
Notes
Notes: svn path=/head/; revision=117140
Diffstat (limited to 'archivers/libarchive/Makefile')
-rw-r--r--archivers/libarchive/Makefile117
1 files changed, 6 insertions, 111 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 85a2e48b2f3d..66424fd295a4 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -5,130 +5,25 @@
# $FreeBSD$
PORTNAME= libarchive
-PORTVERSION= 2004.07.14
+PORTVERSION= 1.01.013
+PORTEPOCH= 1
CATEGORIES= archivers
MASTER_SITES= http://people.freebsd.org/~kientzle/libarchive/src/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
-EXTRACT_SUFX= .tgz
MAINTAINER= glewis@FreeBSD.org
COMMENT= Library to create and read several streaming archive formats
-WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_FLAGS+= INCLUDEDIR=${PREFIX}/include \
- LIBDIR=${PREFIX}/lib \
- MANDIR=${PREFIX}/man/man
+GNU_CONFIGURE= yes
PLIST_FILES= include/archive.h \
include/archive_entry.h \
lib/libarchive.a
-.if !defined(NOPROFILE)
-PLIST_FILES+= lib/libarchive_p.a
-.endif
-MANCOMPRESSED= yes
-MAN3= archive.3 \
- archive_compression.3 \
- archive_compression_name.3 \
- archive_entry.3 \
- archive_entry_acl_add_entry.3 \
- archive_entry_acl_add_entry_w.3 \
- archive_entry_acl_clear.3 \
- archive_entry_acl_count.3 \
- archive_entry_acl_next.3 \
- archive_entry_acl_next_w.3 \
- archive_entry_acl_reset.3 \
- archive_entry_acl_text_w.3 \
- archive_entry_clear.3 \
- archive_entry_clone.3 \
- archive_entry_copy_fflags_text_w.3 \
- archive_entry_copy_gname_w.3 \
- archive_entry_copy_hardlink_w.3 \
- archive_entry_copy_pathname_w.3 \
- archive_entry_copy_stat.3 \
- archive_entry_copy_symlink_w.3 \
- archive_entry_copy_uname_w.3 \
- archive_entry_fflags.3 \
- archive_entry_fflags_text.3 \
- archive_entry_free.3 \
- archive_entry_gid.3 \
- archive_entry_gname.3 \
- archive_entry_gname_w.3 \
- archive_entry_hardlink.3 \
- archive_entry_ino.3 \
- archive_entry_mode.3 \
- archive_entry_mtime.3 \
- archive_entry_mtime_nsec.3 \
- archive_entry_new.3 \
- archive_entry_pathname.3 \
- archive_entry_pathname_w.3 \
- archive_entry_rdev.3 \
- archive_entry_rdevmajor.3 \
- archive_entry_rdevminor.3 \
- archive_entry_set_fflags.3 \
- archive_entry_set_gid.3 \
- archive_entry_set_gname.3 \
- archive_entry_set_hardlink.3 \
- archive_entry_set_link.3 \
- archive_entry_set_mode.3 \
- archive_entry_set_pathname.3 \
- archive_entry_set_rdevmajor.3 \
- archive_entry_set_rdevminor.3 \
- archive_entry_set_size.3 \
- archive_entry_set_symlink.3 \
- archive_entry_set_uid.3 \
- archive_entry_set_uname.3 \
- archive_entry_size.3 \
- archive_entry_stat.3 \
- archive_entry_symlink.3 \
- archive_entry_uid.3 \
- archive_entry_uname.3 \
- archive_entry_uname_w.3 \
- archive_errno.3 \
- archive_error_string.3 \
- archive_format.3 \
- archive_format_name.3 \
+MANCOMPRESSED= no
+MAN3= archive_entry.3 \
archive_read.3 \
- archive_read_data.3 \
- archive_read_data_block.3 \
- archive_read_data_into_buffer.3 \
- archive_read_data_into_fd.3 \
- archive_read_data_skip.3 \
- archive_read_extract.3 \
- archive_read_extract_set_progress_callback.3 \
- archive_read_finish.3 \
- archive_read_new.3 \
- archive_read_next_header.3 \
- archive_read_open.3 \
- archive_read_open_fd.3 \
- archive_read_open_file.3 \
- archive_read_set_bytes_per_block.3 \
- archive_read_support_compression_all.3 \
- archive_read_support_compression_bzip2.3 \
- archive_read_support_compression_compress.3 \
- archive_read_support_compression_gzip.3 \
- archive_read_support_compression_none.3 \
- archive_read_support_format_all.3 \
- archive_read_support_format_cpio.3 \
- archive_read_support_format_tar.3 \
archive_util.3 \
archive_write.3 \
- archive_write_data.3 \
- archive_write_finish.3 \
- archive_write_header.3 \
- archive_write_new.3 \
- archive_write_open.3 \
- archive_write_open_fd.3 \
- archive_write_open_file.3 \
- archive_write_prepare.3 \
- archive_write_set_bytes_in_last_block.3 \
- archive_write_set_bytes_per_block.3 \
- archive_write_set_callbacks.3 \
- archive_write_set_compression_bzip2.3 \
- archive_write_set_compression_gzip.3 \
- archive_write_set_format_pax.3 \
- archive_write_set_format_shar.3 \
- archive_write_set_format_ustar.3 \
libarchive.3
MAN5= libarchive-formats.5 \
tar.5
@@ -136,7 +31,7 @@ MAN5= libarchive-formats.5 \
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502103
-IGNORE= is in the base system
+IGNORE= is in the base system
.endif
.include <bsd.port.post.mk>