aboutsummaryrefslogtreecommitdiff
path: root/archivers/libarchive/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-06-16 15:20:49 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-06-16 15:20:49 +0000
commit5ec76123f1182a0442cebf13545ac1bcb32586a3 (patch)
tree9a4dea44f48310886b2109029b3e2869841beb66 /archivers/libarchive/Makefile
parent0524f4d7a1f5165fb4342eda75e298b97360932b (diff)
downloadports-5ec76123f1182a0442cebf13545ac1bcb32586a3.tar.gz
ports-5ec76123f1182a0442cebf13545ac1bcb32586a3.zip
. Update to 2004.06.07.
Notes
Notes: svn path=/head/; revision=111599
Diffstat (limited to 'archivers/libarchive/Makefile')
-rw-r--r--archivers/libarchive/Makefile31
1 files changed, 23 insertions, 8 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 29357b6b22ed..3943de5099df 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -5,8 +5,8 @@
# $FreeBSD$
PORTNAME= libarchive
-PORTVERSION= 2004.04.08
-CATEGORIES= archivers devel
+PORTVERSION= 2004.06.07
+CATEGORIES= archivers
MASTER_SITES= http://people.freebsd.org/~kientzle/libarchive/src/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
EXTRACT_SUFX= .tgz
@@ -33,39 +33,52 @@ MAN3= archive.3 \
archive_entry.3 \
archive_entry_clear.3 \
archive_entry_clone.3 \
+ archive_entry_copy_fflags_text_w.3 \
+ archive_entry_copy_gname_w.3 \
+ archive_entry_copy_hardlink_w.3 \
+ archive_entry_copy_pathname_w.3 \
archive_entry_copy_stat.3 \
- archive_entry_dup.3 \
+ archive_entry_copy_symlink_w.3 \
+ archive_entry_copy_uname_w.3 \
+ archive_entry_fflags.3 \
+ archive_entry_fflags_text.3 \
archive_entry_free.3 \
archive_entry_gname.3 \
+ archive_entry_gname_w.3 \
archive_entry_hardlink.3 \
+ archive_entry_hardlink_w.3 \
archive_entry_new.3 \
archive_entry_pathname.3 \
+ archive_entry_pathname_w.3 \
archive_entry_set_devmajor.3 \
archive_entry_set_devminor.3 \
archive_entry_set_gid.3 \
archive_entry_set_gname.3 \
archive_entry_set_hardlink.3 \
+ archive_entry_set_link.3 \
archive_entry_set_mode.3 \
archive_entry_set_pathname.3 \
archive_entry_set_symlink.3 \
- archive_entry_set_tartype.3 \
archive_entry_set_uid.3 \
archive_entry_set_uname.3 \
archive_entry_size.3 \
archive_entry_stat.3 \
archive_entry_symlink.3 \
- archive_entry_tartype.3 \
+ archive_entry_symlink_w.3 \
archive_entry_uname.3 \
+ archive_entry_uname_w.3 \
archive_errno.3 \
archive_error_string.3 \
archive_format.3 \
archive_format_name.3 \
archive_read.3 \
archive_read_data.3 \
+ archive_read_data_block.3 \
archive_read_data_into_buffer.3 \
- archive_read_data_into_file.3 \
+ archive_read_data_into_fd.3 \
archive_read_data_skip.3 \
archive_read_extract.3 \
+ archive_read_extract_set_progress_callback.3 \
archive_read_finish.3 \
archive_read_new.3 \
archive_read_next_header.3 \
@@ -75,11 +88,11 @@ MAN3= archive.3 \
archive_read_set_bytes_per_block.3 \
archive_read_support_compression_all.3 \
archive_read_support_compression_bzip2.3 \
+ archive_read_support_compression_compress.3 \
archive_read_support_compression_gzip.3 \
archive_read_support_compression_none.3 \
archive_read_support_format_all.3 \
archive_read_support_format_cpio.3 \
- archive_read_support_format_gnutar.3 \
archive_read_support_format_tar.3 \
archive_util.3 \
archive_write.3 \
@@ -97,9 +110,11 @@ MAN3= archive.3 \
archive_write_set_compression_bzip2.3 \
archive_write_set_compression_gzip.3 \
archive_write_set_format_pax.3 \
+ archive_write_set_format_shar.3 \
archive_write_set_format_ustar.3 \
libarchive.3
-MAN5= tar.5
+MAN5= libarchive-formats.5 \
+ tar.5
.include <bsd.port.pre.mk>