aboutsummaryrefslogtreecommitdiff
path: root/archivers/libcabinet
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-10-26 02:55:52 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-10-26 02:55:52 +0000
commit76f26d3acf6f9543a3a7f98e53a1d24567ab5b6b (patch)
treee03a24e7a2e79afe60bef46f4af3cef4637a6c1a /archivers/libcabinet
parent565a4bfeef3d02a72f8a4542627bd3ab2dbe388b (diff)
downloadports-76f26d3acf6f9543a3a7f98e53a1d24567ab5b6b.tar.gz
ports-76f26d3acf6f9543a3a7f98e53a1d24567ab5b6b.zip
Mark BROKEN on 5.0
Notes
Notes: svn path=/head/; revision=68849
Diffstat (limited to 'archivers/libcabinet')
-rw-r--r--archivers/libcabinet/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/archivers/libcabinet/Makefile b/archivers/libcabinet/Makefile
index e49b87ee2be5..75e1fbe0e2f5 100644
--- a/archivers/libcabinet/Makefile
+++ b/archivers/libcabinet/Makefile
@@ -17,6 +17,12 @@ INSTALLS_SHLIB= yes
SRCFILE= ${WRKSRC}/listcab.cpp
PROGFILE= ${SRCFILE:S/.cpp$//}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500035
+BROKEN= "Does not compile on 5.0"
+.endif
+
post-build:
${CXX} ${CXXFLAGS} -o ${PROGFILE} ${SRCFILE} -L${WRKSRC} -lcabinet
@@ -26,4 +32,4 @@ pre-install:
post-install:
${INSTALL_PROGRAM} ${PROGFILE} ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>