aboutsummaryrefslogtreecommitdiff
path: root/archivers/liblz4
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-10-26 00:14:05 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-10-26 00:14:05 +0000
commit26979cac5886e5900899c326880ba690402958c6 (patch)
treeac176289eff673e3808b1430a77339dcf2343ffe /archivers/liblz4
parent32bcfd1eed37151eb964e565d436417720b99ac4 (diff)
downloadports-26979cac5886e5900899c326880ba690402958c6.tar.gz
ports-26979cac5886e5900899c326880ba690402958c6.zip
Add archivers/liblz4. There is already archivers/lz4, which it looks
like might be an old version of this, but it only installs a binary. This installs binaries and libraries/headers. LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems. A high compression derivative, called LZ4_HC, is also provided. It trades CPU time for compression ratio. The libraries are BSD licensed, and the binaries are GPLv2. WWW: https://code.google.com/p/lz4/
Notes
Notes: svn path=/head/; revision=371493
Diffstat (limited to 'archivers/liblz4')
-rw-r--r--archivers/liblz4/Makefile51
-rw-r--r--archivers/liblz4/distinfo2
-rw-r--r--archivers/liblz4/pkg-descr11
-rw-r--r--archivers/liblz4/pkg-plist13
4 files changed, 77 insertions, 0 deletions
diff --git a/archivers/liblz4/Makefile b/archivers/liblz4/Makefile
new file mode 100644
index 000000000000..44f0a647f51b
--- /dev/null
+++ b/archivers/liblz4/Makefile
@@ -0,0 +1,51 @@
+# Created by: adamw
+# $FreeBSD$
+
+PORTNAME= lz4
+PORTVERSION= 123
+CATEGORIES= archivers
+PKGNAMEPREFIX= lib
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= LZ4 compression library, lossless and very fast
+
+LICENSE= BSD2CLAUSE GPLv2
+LICENSE_COMB= multi
+
+USE_GITHUB= yes
+GH_ACCOUNT= Cyan4973
+GH_PROJECT= lz4
+GH_TAGNAME= r${PORTVERSION}
+GH_COMMIT= c0054ca
+
+CONFLICTS= lz4-*
+
+USES= gmake pkgconfig
+USE_LDCONFIG= yes
+
+ALL_TARGET= all liblz4 liblz4.pc
+SO_VER= 1.3.1
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|kFreeBSD|& FreeBSD|' \
+ ${WRKSRC}/Makefile ${WRKSRC}/programs/Makefile
+ ${REINPLACE_CMD} -e '/^all:/s|fullbench.*||' \
+ ${WRKSRC}/programs/Makefile
+
+do-install:
+ ${INSTALL_LIB} ${WRKSRC}/liblz4.so.${SO_VER} ${STAGEDIR}${PREFIX}/lib
+ ${LN} -sf liblz4.so.${SO_VER} ${STAGEDIR}${PREFIX}/lib/liblz4.so.${SO_VER:R:R}
+ ${LN} -sf liblz4.so.${SO_VER:R:R} ${STAGEDIR}${PREFIX}/lib/liblz4.so
+ ${INSTALL_LIB} ${WRKSRC}/liblz4.a ${STAGEDIR}${PREFIX}/lib
+
+ ${INSTALL_DATA} ${WRKSRC}/liblz4.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ ${INSTALL_DATA} ${WRKSRC}/lz4.h ${WRKSRC}/lz4hc.h ${STAGEDIR}${PREFIX}/include
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/programs/lz4 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/programs/lz4c ${STAGEDIR}${PREFIX}/bin
+ ${LN} -sf lz4 ${STAGEDIR}${PREFIX}/bin/lz4cat
+ ${INSTALL_MAN} ${WRKSRC}/programs/lz4.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/programs/lz4c.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/programs/lz4cat.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/archivers/liblz4/distinfo b/archivers/liblz4/distinfo
new file mode 100644
index 000000000000..f10e54402f89
--- /dev/null
+++ b/archivers/liblz4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lz4-123.tar.gz) = 8b0f6aaeb854ee7f5fe9b07cbe83e470be4cb434c4f492aead1c7989c87af9bf
+SIZE (lz4-123.tar.gz) = 137372
diff --git a/archivers/liblz4/pkg-descr b/archivers/liblz4/pkg-descr
new file mode 100644
index 000000000000..2e0a49c7098c
--- /dev/null
+++ b/archivers/liblz4/pkg-descr
@@ -0,0 +1,11 @@
+LZ4 is a very fast lossless compression algorithm, providing compression speed
+at 400 MB/s per core, scalable with multi-cores CPU. It also features an
+extremely fast decoder, with speed in multiple GB/s per core, typically
+reaching RAM speed limits on multi-core systems.
+
+A high compression derivative, called LZ4_HC, is also provided. It trades CPU
+time for compression ratio.
+
+The libraries are BSD licensed, and the binaries are GPLv2.
+
+WWW: https://code.google.com/p/lz4/
diff --git a/archivers/liblz4/pkg-plist b/archivers/liblz4/pkg-plist
new file mode 100644
index 000000000000..ccab23e0b403
--- /dev/null
+++ b/archivers/liblz4/pkg-plist
@@ -0,0 +1,13 @@
+bin/lz4
+bin/lz4c
+bin/lz4cat
+include/lz4.h
+include/lz4hc.h
+lib/liblz4.a
+lib/liblz4.so
+lib/liblz4.so.1
+lib/liblz4.so.1.3.1
+libdata/pkgconfig/liblz4.pc
+man/man1/lz4.1.gz
+man/man1/lz4c.1.gz
+man/man1/lz4cat.1.gz