aboutsummaryrefslogtreecommitdiff
path: root/archivers/liborange
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-06-17 21:47:05 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-06-17 21:47:05 +0000
commit74ebb2383587b7062608925dd8425ae5d1fb2a29 (patch)
treecdde8d26a829778ea0651e6aa75cd6a570f1d4b9 /archivers/liborange
parent07ae4c345d5615043875e6a37506cbcb6a1cc79a (diff)
downloadports-74ebb2383587b7062608925dd8425ae5d1fb2a29.tar.gz
ports-74ebb2383587b7062608925dd8425ae5d1fb2a29.zip
- Repocopy archivers/orange to archivers/liborange.
- Update to 0.3.2. PR: ports/124402 Submitted by: Alexander Logvinov <ports@logvinov.com> (maintainer)
Notes
Notes: svn path=/head/; revision=215032
Diffstat (limited to 'archivers/liborange')
-rw-r--r--archivers/liborange/Makefile64
-rw-r--r--archivers/liborange/distinfo6
-rw-r--r--archivers/liborange/files/patch-inno.h28
-rw-r--r--archivers/liborange/pkg-descr2
-rw-r--r--archivers/liborange/pkg-plist2
5 files changed, 64 insertions, 38 deletions
diff --git a/archivers/liborange/Makefile b/archivers/liborange/Makefile
index 43daa055ef53..ce3c407b5f8a 100644
--- a/archivers/liborange/Makefile
+++ b/archivers/liborange/Makefile
@@ -5,26 +5,68 @@
# $FreeBSD$
#
-PORTNAME= orange
-PORTVERSION= 0.3
-PORTREVISION= 2
+PORTNAME= liborange
+PORTVERSION= 0.3.2
CATEGORIES= archivers
MASTER_SITES= SF
MASTER_SITE_SUBDIR= synce
MAINTAINER= ports@logvinov.com
-COMMENT= Extract Microsoft Cabinet files from self-extracting installers
+COMMENT= Library to extract CAB files from self-extracting installers
-LIB_DEPENDS= synce.0:${PORTSDIR}/palm/synce-libsynce \
- rapi.2:${PORTSDIR}/palm/synce-librapi2 \
- dynamite.0:${PORTSDIR}/archivers/libdynamite \
- unshield.0:${PORTSDIR}/archivers/unshield
+OPTIONS= LIBSYNCE "Build with libsynce support" on \
+ LIBDYNAMITE "Build with libdynamite support" on \
+ LIBUNSHIELD "Build with libunshield support" on \
+ INNO "Build with expermential Inno Setup support" off \
+ VISE "Build with expermential VISE support" off \
+ MSI "Build with expermential MSI support" off
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-USE_GNOME= gnometarget
-CONFIGURE_ARGS= --with-libsynce=${LOCALBASE}
+USE_GNOME= gnomehack gnometarget
USE_ICONV= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
-.include <bsd.port.mk>
+MAN1= orange.1
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_LIBSYNCE)
+CONFIGURE_ARGS+= --without-libsynce
+.else
+LIB_DEPENDS+= synce.0:${PORTSDIR}/palm/synce-libsynce
+CONFIGURE_ARGS+= --with-libsynce=${LOCALBASE}
+.endif
+
+.if !defined(WITH_LIBDYNAMITE)
+CONFIGURE_ARGS+= --without-libdynamite
+.else
+LIB_DEPENDS+= dynamite.0:${PORTSDIR}/archivers/libdynamite
+CONFIGURE_ARGS+= --with-libdynamite=${LOCALBASE}
+.endif
+
+.if !defined(WITH_LIBUNSHIELD)
+CONFIGURE_ARGS+= --without-libunshield
+.else
+LIB_DEPENDS+= unshield.0:${PORTSDIR}/archivers/unshield
+CONFIGURE_ARGS+= --with-libunshield=${LOCALBASE}
+.endif
+
+.if defined(WITH_INNO)
+CONFIGURE_ARGS+= --enable-inno
+.endif
+
+.if defined(WITH_VISE)
+CONFIGURE_ARGS+= --enable-vise
+.endif
+
+.if defined(WITH_MSI)
+CONFIGURE_ARGS+= --enable-msi --with-libgsf
+LIB_DEPENDS+= gsf-1.114:${PORTSDIR}/devel/libgsf
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/liborange/distinfo b/archivers/liborange/distinfo
index 7c6ffc3ffc49..07ee5e146564 100644
--- a/archivers/liborange/distinfo
+++ b/archivers/liborange/distinfo
@@ -1,3 +1,3 @@
-MD5 (orange-0.3.tar.gz) = 90f6e822bb81af886dce5bdecd227655
-SHA256 (orange-0.3.tar.gz) = 828cc7c7b7c21e0d8e5e3143b1428bbc1f4cfab7f9af934fe1b110fe7d333e41
-SIZE (orange-0.3.tar.gz) = 336931
+MD5 (liborange-0.3.2.tar.gz) = 52f9fb2b97ee08b4929079ed68ba16a0
+SHA256 (liborange-0.3.2.tar.gz) = 5aed6ae32a2e103bd846c02a55b7d802fb1b6c2676207fba62d2a0ec944f57a1
+SIZE (liborange-0.3.2.tar.gz) = 380034
diff --git a/archivers/liborange/files/patch-inno.h b/archivers/liborange/files/patch-inno.h
index 2d3cd73d60ed..e34969a54f5e 100644
--- a/archivers/liborange/files/patch-inno.h
+++ b/archivers/liborange/files/patch-inno.h
@@ -1,5 +1,5 @@
---- lib/inno.h.orig Mon Sep 8 17:17:28 2003
-+++ lib/inno.h Mon Jan 10 05:07:47 2005
+--- lib/inno.h.orig 2008-05-22 15:55:23.000000000 +1000
++++ lib/inno.h 2008-05-22 15:57:49.000000000 +1000
@@ -3,7 +3,7 @@
#define __inno_h__
@@ -9,7 +9,7 @@
#include <stdio.h>
#include <zlib.h>
-@@ -100,7 +100,7 @@
+@@ -99,7 +99,7 @@
uint32_t NumUninstallDeleteEntries;
uint32_t NumRunEntries;
uint32_t NumUninstallRunEntries;
@@ -18,7 +18,7 @@
} TSetupHeader;
#define SETUP_HEADER_SIZE 0xd9
-@@ -144,9 +144,9 @@
+@@ -143,9 +143,9 @@
typedef struct
{
@@ -31,7 +31,7 @@
} TSetupVersionData;
#if 0
-@@ -173,12 +173,12 @@
+@@ -172,12 +172,12 @@
char* InstallFontName;
char* Components;
char* Tasks;
@@ -47,21 +47,3 @@
#if 0
Options: set of (foConfirmOverwrite, foUninsNeverUninstall, foRestartReplace,
foDeleteAfterInstall, foRegisterServer, foRegisterTypeLib, foSharedFile,
-@@ -191,7 +191,7 @@
- #endif
- } TSetupFileEntry;
-
--P typedef struct
-+typedef struct
- {
- uint32_t FirstDisk;
- uint32_t LastDisk;
-@@ -202,7 +202,7 @@
- uint32_t Date;
- uint32_t FileVersionMS;
- uint32_t FileVersionLS;
--} TSetupFileLocationEntry;
-+} P TSetupFileLocationEntry;
-
- #define SETUP_FILE_LOCATION_ENTRY_SIZE 0x29
-
diff --git a/archivers/liborange/pkg-descr b/archivers/liborange/pkg-descr
index e0fb7124737c..22fdd4a03b78 100644
--- a/archivers/liborange/pkg-descr
+++ b/archivers/liborange/pkg-descr
@@ -4,4 +4,4 @@ Windows.
Supported installers include VISE, InstallShield, Setup Factory and more.
-WWW: http://synce.sourceforge.net
+WWW: http://synce.sourceforge.net/
diff --git a/archivers/liborange/pkg-plist b/archivers/liborange/pkg-plist
index 6bd214029cb4..45f095d45a67 100644
--- a/archivers/liborange/pkg-plist
+++ b/archivers/liborange/pkg-plist
@@ -1,6 +1,8 @@
bin/orange
include/liborange.h
+include/liborange_stub.h
lib/liborange.a
lib/liborange.la
lib/liborange.so
lib/liborange.so.0
+libdata/pkgconfig/liborange.pc