aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-POE-Filter-LZF/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-27 08:45:14 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-27 08:45:14 +0000
commitb5f5d0810124299ee3f77c5429fdb4245475713c (patch)
treeb6fc78370541ca410ab2b608d434fd4c7a7703f5 /archivers/p5-POE-Filter-LZF/Makefile
parente4b9fe982debe0d7e7b74a2bd48312c13313885c (diff)
downloadports-b5f5d0810124299ee3f77c5429fdb4245475713c.tar.gz
ports-b5f5d0810124299ee3f77c5429fdb4245475713c.zip
Add p5-POE-Filter-LZF 1.5, a POE filter wrapped around Compress::LZF.
PR: ports/103096 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=173958
Diffstat (limited to 'archivers/p5-POE-Filter-LZF/Makefile')
-rw-r--r--archivers/p5-POE-Filter-LZF/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/archivers/p5-POE-Filter-LZF/Makefile b/archivers/p5-POE-Filter-LZF/Makefile
new file mode 100644
index 000000000000..b307ec584184
--- /dev/null
+++ b/archivers/p5-POE-Filter-LZF/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-POE-Filter-LZF
+# Date created: 2006-09-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Filter-LZF
+PORTVERSION= 1.5
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A POE filter wrapped around Compress::LZF
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Compress/LZF.pm:${PORTSDIR}/archivers/p5-Compress-LZF \
+ p5-POE>=0.3501:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Filter::LZF.3
+
+.include <bsd.port.mk>