aboutsummaryrefslogtreecommitdiff
path: root/archivers/p7zip/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-30 12:23:53 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-30 12:23:53 +0000
commit8248f236b6528da5635f2c5da19d4440c1910675 (patch)
treeb12af0eb32b2da874e14a434931d3878ee276cdb /archivers/p7zip/Makefile
parentd0bf4096040d8a454bed8e687079753c7dfcfde2 (diff)
downloadports-8248f236b6528da5635f2c5da19d4440c1910675.tar.gz
ports-8248f236b6528da5635f2c5da19d4440c1910675.zip
Fix post-patch: sed(1) expression s/// cannot receive tokens with
/ in their composition which breaks C{C,XX} with path components such as those used by users of devel/ccache, e.g., CC=/usr/local/libexec/ccache/cc Approved by: maintainer
Notes
Notes: svn path=/head/; revision=127698
Diffstat (limited to 'archivers/p7zip/Makefile')
-rw-r--r--archivers/p7zip/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
index ce44b87f2ae5..0e698efdeca4 100644
--- a/archivers/p7zip/Makefile
+++ b/archivers/p7zip/Makefile
@@ -42,8 +42,8 @@ IGNORE= requires wchar functions (mbrtowc(3) etc.) for compilation
post-patch:
${SED} -e 's/-O2/${CFLAGS} ${PTHREAD_CFLAGS}/' \
- -e 's/g\+\+/${CXX}/' \
- -e 's/gcc/${CC}/' \
+ -e 's!g\+\+!${CXX}!' \
+ -e 's!gcc!${CC}!' \
-e '/LITTLE_ENDIAN/d' \
-e 's/-lc_r/${PTHREAD_LIBS}/' \
${WRKSRC}/makefile.freebsd_x86 > ${WRKSRC}/makefile.machine