aboutsummaryrefslogtreecommitdiff
path: root/archivers/p7zip/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-08-11 18:07:36 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-08-11 18:07:36 +0000
commita0b4fb6047723252c01516580db8250d3b970dab (patch)
tree111174caff12dad7152835ec18a3e9b296b8e67e /archivers/p7zip/Makefile
parent830d958b882af4e502ccca38977c6bab01ff3ff7 (diff)
downloadports-a0b4fb6047723252c01516580db8250d3b970dab.tar.gz
ports-a0b4fb6047723252c01516580db8250d3b970dab.zip
file archiver with highest compression ratio
PR: ports/69248 Submitted by: Juergen Lock <nox@jelal.kn-bremen.de>
Notes
Notes: svn path=/head/; revision=115949
Diffstat (limited to 'archivers/p7zip/Makefile')
-rw-r--r--archivers/p7zip/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
new file mode 100644
index 000000000000..3a92e3e0afa2
--- /dev/null
+++ b/archivers/p7zip/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p7zip
+# Date created: Sun Jul 18 15:07:26 CEST 2004
+# Whom: Juergen Lock <nox@jelal.kn-bremen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= p7zip
+PORTVERSION= 0.90
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= p7zip
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= nox@jelal.kn-bremen.de
+COMMENT= Command line versions of 7-zip
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+MAKEFILE= makefile
+MAKE_ARGS+= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
+ONLY_FOR_ARCHS= alpha amd64 i386 ia64
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500039
+BROKEN= Requires wchar functions (mbrtowc(3) etc.) for compilation
+.endif
+
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/p7zip/Codecs
+ ${MKDIR} ${PREFIX}/libexec/p7zip/Formats
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/7z ${PREFIX}/libexec/p7zip
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/7za ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/bin/Codecs/* ${PREFIX}/libexec/p7zip/Codecs
+ ${INSTALL_DATA} ${WRKSRC}/bin/Formats/* ${PREFIX}/libexec/p7zip/Formats
+ ${INSTALL_SCRIPT} ${FILESDIR}/7z ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/doc/p7zip/commands
+ ${MKDIR} ${PREFIX}/share/doc/p7zip/switches
+ ${INSTALL_DATA} ${WRKSRC}/html/cmdline/*.htm ${PREFIX}/share/doc/p7zip
+ ${INSTALL_DATA} ${WRKSRC}/html/cmdline/commands/* ${PREFIX}/share/doc/p7zip/commands
+ ${INSTALL_DATA} ${WRKSRC}/html/cmdline/switches/* ${PREFIX}/share/doc/p7zip/switches
+
+.include <bsd.port.post.mk>