aboutsummaryrefslogtreecommitdiff
path: root/archivers/p7zip/Makefile
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2004-12-28 02:46:57 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2004-12-28 02:46:57 +0000
commita3154e38e899e5c4dd5d858ac556bd413b7c2d09 (patch)
tree2a9ac8d1f0254fac1a009c021953876bcca60c53 /archivers/p7zip/Makefile
parent2bb1a3a5ea92c70b572f35d9b99c8580272e4be8 (diff)
downloadports-a3154e38e899e5c4dd5d858ac556bd413b7c2d09.tar.gz
ports-a3154e38e899e5c4dd5d858ac556bd413b7c2d09.zip
update to 4.13.
o Ressurect pkg-plist to support to make modules optional. 25 lines out of 31 are wrapped with %%MODULES%% which can be controlled by WITHOUT_MODULES knob. The modules support more codecs and formats than stand-alone binary. o Install 7za to libexec and wrap it with script to support sfx creation. 7za and .sfx should be placed in the same directory as 7z and modules do. o Wrapper script executes corresponding binary (7z or 7za.) In WITHOUT_MODULES case, it can be called by 7z or 7za but always executes 7za. This is compatible action for previous port. o Turn BROKEN to IGNORE. There is no hope to compile this software in RELENG_4. And correct quotation for this change. Approved by: maintainer
Notes
Notes: svn path=/head/; revision=125306
Diffstat (limited to 'archivers/p7zip/Makefile')
-rw-r--r--archivers/p7zip/Makefile33
1 files changed, 26 insertions, 7 deletions
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
index a2adc9624acd..991a4b142fea 100644
--- a/archivers/p7zip/Makefile
+++ b/archivers/p7zip/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= p7zip
-PORTVERSION= 4.12
+PORTVERSION= 4.13
CATEGORIES= archivers
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= p7zip
@@ -20,15 +20,24 @@ USE_GMAKE= yes
MAKEFILE= makefile
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
-PLIST_FILES= "@unexec ${RM} %D/bin/7z"
-PLIST_FILES+= bin/7za
-PLIST_FILES+= "@exec ${LN} -sf 7za %D/bin/7z"
PORTDOCS= *
+DLLDIR= ${PREFIX}/libexec/p7zip
+7ZBIN= 7za 7zCon.sfx
+
+.if defined(WITHOUT_MODULES)
+PLIST_SUB= MODULES="@comment "
+ALL_TARGET= 7za sfx
+.else
+PLIST_SUB= MODULES=""
+ALL_TARGET= all2
+7ZBIN+= 7z
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500039
-BROKEN= 'Requires wchar functions (mbrtowc(3) etc.) for compilation'
+IGNORE= requires wchar functions (mbrtowc(3) etc.) for compilation
.endif
post-patch:
@@ -40,8 +49,18 @@ post-patch:
${WRKSRC}/makefile.freebsd_x86 > ${WRKSRC}/makefile.machine
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/7za ${PREFIX}/bin
- ${LN} -sf 7za ${PREFIX}/bin/7z
+ ${MKDIR} ${DLLDIR}
+.for f in ${7ZBIN}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${f} ${DLLDIR}
+.endfor
+ ${INSTALL_SCRIPT} ${FILESDIR}/7z ${PREFIX}/bin
+ ${LN} -sf 7z ${PREFIX}/bin/7za
+.if !defined(WITHOUT_MODULES)
+.for f in Codecs Formats
+ ${MKDIR} ${DLLDIR}/${f}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${f}/* ${DLLDIR}/${f}
+.endfor
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${PAX} -rw -s,${WRKSRC}/DOCS,, ${WRKSRC}/DOCS ${DOCSDIR}