aboutsummaryrefslogtreecommitdiff
path: root/archivers/p7zip/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-10-07 19:10:45 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-10-07 19:10:45 +0000
commitc0915380f7209ca8fc1d1c88047f06875a61c13d (patch)
treed578b111637ed2600237d7cfc15b73681c1ffb75 /archivers/p7zip/Makefile
parent8d9684cf7b434d5df41ccc76cc2bbdea5d1609e8 (diff)
downloadports-c0915380f7209ca8fc1d1c88047f06875a61c13d.tar.gz
ports-c0915380f7209ca8fc1d1c88047f06875a61c13d.zip
Pass -fPIC on armv7 as well.
This fixes the following build error: /usr/bin/ld: 7zEncode.o(.text+0x2d04): unresolvable R_ARM_MOVW_ABS_NC relocation against symbol `_ZTIi@@CXXABI_1.3' /usr/bin/ld: final link failed: Nonrepresentable section on output c++: error: linker command failed with exit code 1 (use -v to see invocation) PR: 222852 Submitted by: guyyur@gmail.com
Notes
Notes: svn path=/head/; revision=451477
Diffstat (limited to 'archivers/p7zip/Makefile')
-rw-r--r--archivers/p7zip/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
index fbaaf469975c..9e2c2a21deec 100644
--- a/archivers/p7zip/Makefile
+++ b/archivers/p7zip/Makefile
@@ -20,6 +20,7 @@ MAKEFILE= makefile
MAKE_ARGS= OPTFLAGS="${CXXFLAGS}"
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
+CFLAGS_armv7= -fPIC
CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
CFLAGS_powerpc= -fPIC