aboutsummaryrefslogtreecommitdiff
path: root/archivers/p7zip/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-11-25 22:49:35 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-11-25 22:49:35 +0000
commitec8ff07771ba0c403b9ef91f82cfda6aa650a02f (patch)
tree4ae10de236a5395ebc40a6fd404d58b5669a040a /archivers/p7zip/Makefile
parentd8a6c9d66f308c93660d9e605f75ac20db9ccf37 (diff)
downloadports-ec8ff07771ba0c403b9ef91f82cfda6aa650a02f.tar.gz
ports-ec8ff07771ba0c403b9ef91f82cfda6aa650a02f.zip
Convert to OptionsNG.
PR: ports/173813 Submitted by: Chris Petrik <c.petrik.sosa@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=307758
Diffstat (limited to 'archivers/p7zip/Makefile')
-rw-r--r--archivers/p7zip/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
index fa9fd63ad9e5..5bc7e76bb93c 100644
--- a/archivers/p7zip/Makefile
+++ b/archivers/p7zip/Makefile
@@ -10,8 +10,11 @@ DISTNAME= ${PORTNAME}_${DISTVERSION}_src_all
MAINTAINER= rakuco@FreeBSD.org
COMMENT= File archiver with high compression ratio
-OPTIONS= MINIMAL "Support only .7z file format" off \
- MODULES "Build modules" on
+OPTIONS_DEFINE= MINIMAL MODULES
+OPTIONS_DEFAULT= MODULES
+
+MINIMAL_DESC= Support only .7z file format
+MODULES_DESC= Build modules
USE_BZIP2= yes
MAKEFILE= makefile
@@ -19,7 +22,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
.include <bsd.port.options.mk>
-.if defined(WITH_MINIMAL)
+.if ${PORT_OPTIONS:MMINIMAL}
MAN1= 7zr.1
MLINKS= 7zr.1 7z.1
PLIST_SUB= MODULES="@comment "
@@ -39,7 +42,7 @@ PLIST_FILES= bin/7z \
libexec/p7zip/7za \
libexec/p7zip/7zr \
libexec/p7zip/7zCon.sfx
-.if !defined(WITHOUT_MODULES)
+.if ${PORT_OPTIONS:MMODULES}
ALL_TARGET= 7z 7za 7zr Client7z sfx
7ZBIN= 7z 7za 7zr Client7z 7zCon.sfx
PLIST_DIRS+= libexec/p7zip/Codecs