aboutsummaryrefslogtreecommitdiff
path: root/archivers/py-attic/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-07-24 23:22:22 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-07-24 23:22:22 +0000
commit7c8b33b083eb812103f9b6968d635390c11fc8ba (patch)
tree9e2d174705896cbd04ba3cb422997ac3e9a76583 /archivers/py-attic/Makefile
parent7fe8ff72d661167f65a5659a0115a336cd6a0827 (diff)
downloadports-7c8b33b083eb812103f9b6968d635390c11fc8ba.tar.gz
ports-7c8b33b083eb812103f9b6968d635390c11fc8ba.zip
For now, ignore on the package builders when default python version is not 3.2+
Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=392850
Diffstat (limited to 'archivers/py-attic/Makefile')
-rw-r--r--archivers/py-attic/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/archivers/py-attic/Makefile b/archivers/py-attic/Makefile
index c870bbe6cc72..60011cc29e0e 100644
--- a/archivers/py-attic/Makefile
+++ b/archivers/py-attic/Makefile
@@ -31,6 +31,10 @@ BUILD_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl
RUN_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl
.endif
+.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
+.endif
+
regression-test: build
${SETENV} PYTHONPATH="${PYDISTUTILS_BUILDPATH}:${PYTHONPATH}" \
${PYTHON_CMD} -m attic.testsuite.run