aboutsummaryrefslogtreecommitdiff
path: root/archivers/py-brotlipy
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-05-17 12:34:14 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-05-17 12:34:14 +0000
commitc81d6079a7a30ea3a4dcedd8383db4bc137eb4ab (patch)
tree4e8a943d0f10ffa38bfcef3f8f7d4f4ee8133842 /archivers/py-brotlipy
parent678d5bb76ed0c3fe47e7d73b5153e83e2b0e02b4 (diff)
downloadports-c81d6079a7a30ea3a4dcedd8383db4bc137eb4ab.tar.gz
ports-c81d6079a7a30ea3a4dcedd8383db4bc137eb4ab.zip
[NEW PORT] archivers/py-brotlipy: Python binding to the Brotli library
Brotlipy is a collection of CFFI-based bindings to the Brotli compression reference implementation as written by Google. This enables Python software to easily and quickly work with the Brotli compression algorithm, regardless of what interpreter is being used. WWW: https://github.com/python-hyper/brotlipy/
Notes
Notes: svn path=/head/; revision=501863
Diffstat (limited to 'archivers/py-brotlipy')
-rw-r--r--archivers/py-brotlipy/Makefile26
-rw-r--r--archivers/py-brotlipy/distinfo3
-rw-r--r--archivers/py-brotlipy/pkg-descr6
3 files changed, 35 insertions, 0 deletions
diff --git a/archivers/py-brotlipy/Makefile b/archivers/py-brotlipy/Makefile
new file mode 100644
index 000000000000..5be49b363c9f
--- /dev/null
+++ b/archivers/py-brotlipy/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= brotlipy
+PORTVERSION= 0.7.0
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Python binding to the Brotli library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR}
+
+py27_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}enum34>=1.0.4,<2.0:devel/py-enum34@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/brotli/*.so
+
+.include <bsd.port.mk>
diff --git a/archivers/py-brotlipy/distinfo b/archivers/py-brotlipy/distinfo
new file mode 100644
index 000000000000..12c7c4637b44
--- /dev/null
+++ b/archivers/py-brotlipy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1558091360
+SHA256 (brotlipy-0.7.0.tar.gz) = 36def0b859beaf21910157b4c33eb3b06d8ce459c942102f16988cca6ea164df
+SIZE (brotlipy-0.7.0.tar.gz) = 413338
diff --git a/archivers/py-brotlipy/pkg-descr b/archivers/py-brotlipy/pkg-descr
new file mode 100644
index 000000000000..2871fc2a21b5
--- /dev/null
+++ b/archivers/py-brotlipy/pkg-descr
@@ -0,0 +1,6 @@
+Brotlipy is a collection of CFFI-based bindings to the Brotli compression
+reference implementation as written by Google. This enables Python software
+to easily and quickly work with the Brotli compression algorithm,
+regardless of what interpreter is being used.
+
+WWW: https://github.com/python-hyper/brotlipy/