aboutsummaryrefslogtreecommitdiff
path: root/archivers/py-librtfcomp/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-10-09 15:24:39 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-10-09 15:24:39 +0000
commit7c38a96ed80ac1c73bb62bd90254ac34840d85be (patch)
tree2c6a1464df484c031ce60497d5e4617673b86634 /archivers/py-librtfcomp/Makefile
parentbee3ac845a44025e7df84c0a3f5021308482892d (diff)
downloadports-7c38a96ed80ac1c73bb62bd90254ac34840d85be.tar.gz
ports-7c38a96ed80ac1c73bb62bd90254ac34840d85be.zip
- Convert from slave port to normal port
Notes
Notes: svn path=/head/; revision=370548
Diffstat (limited to 'archivers/py-librtfcomp/Makefile')
-rw-r--r--archivers/py-librtfcomp/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/archivers/py-librtfcomp/Makefile b/archivers/py-librtfcomp/Makefile
index a437ed274c48..bcedf7703179 100644
--- a/archivers/py-librtfcomp/Makefile
+++ b/archivers/py-librtfcomp/Makefile
@@ -1,7 +1,11 @@
# Created by: Alexander Logvinov <ports@logvinov.com>
# $FreeBSD$
-PORTREVISION= 2
+PORTNAME= librtfcomp
+PORTVERSION= 1.3
+PORTREVISION= 3
+CATEGORIES= archivers python
+MASTER_SITES= SF/synce/SynCE/${PORTNAME}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
@@ -12,16 +16,22 @@ LICENSE= LGPL21
BUILD_DEPENDS= ${LOCALBASE}/bin/pyrexc:${PORTSDIR}/devel/pyrex
LIB_DEPENDS= librtfcomp.so:${PORTSDIR}/archivers/librtfcomp
-USES= python:2
+CONFIGURE_ARGS= --enable-python-bindings
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= libtool python:2
BUILD_WRKSRC= ${WRKSRC}/python
INSTALL_WRKSRC= ${WRKSRC}/python
-PLIST= ${NONEXISTENT}
PLIST_FILES= %%PYTHON_SITELIBDIR%%/pyrtfcomp.a \
%%PYTHON_SITELIBDIR%%/pyrtfcomp.so
-MASTERDIR= ${.CURDIR}/../librtfcomp
-SLAVEPORT= py
+post-patch:
+ @${REINPLACE_CMD} -e '/VISIBILITY=/ s| -fvisibility=hidden||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|[^ ]*/src/librtfcomp\.la||' ${WRKSRC}/python/Makefile.in
-.include "${MASTERDIR}/Makefile"
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/pyrtfcomp.so
+
+.include <bsd.port.mk>