aboutsummaryrefslogtreecommitdiff
path: root/archivers/py-librtfcomp/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2008-06-19 22:06:13 +0000
committerErwin Lansing <erwin@FreeBSD.org>2008-06-19 22:06:13 +0000
commit8b0ba84c09fcd353eea2521cd6ca8e57f82eb781 (patch)
treea21f23109e2dc7d292a967eb6050bba8bfccd7df /archivers/py-librtfcomp/Makefile
parent54a151c57f683fe85dd05d018e3221f8ede2f308 (diff)
downloadports-8b0ba84c09fcd353eea2521cd6ca8e57f82eb781.tar.gz
ports-8b0ba84c09fcd353eea2521cd6ca8e57f82eb781.zip
Add py-librtfcomp , LZRTF compression library.
PR: ports/124554 Submitted by: Alexander Logvinov <ports at logvinov.com>
Notes
Notes: svn path=/head/; revision=215310
Diffstat (limited to 'archivers/py-librtfcomp/Makefile')
-rw-r--r--archivers/py-librtfcomp/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/archivers/py-librtfcomp/Makefile b/archivers/py-librtfcomp/Makefile
new file mode 100644
index 000000000000..f589cf85d99f
--- /dev/null
+++ b/archivers/py-librtfcomp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-librtfcomp
+# Date Created: 13 June 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= archivers python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@logvinov.com
+COMMENT= Python bindings for the LZRTF compression library
+
+LIB_DEPENDS= rtfcomp.0:${PORTSDIR}/archivers/librtfcomp
+BUILD_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex
+
+MASTERDIR= ${.CURDIR}/../librtfcomp
+
+USE_PYTHON= yes
+
+PLIST= ${.CURDIR}/pkg-plist
+
+RTFCOMP_SLAVE= pythonb
+
+do-install:
+ @(cd ${WRKSRC}/python && ${MAKE} install)
+
+.include "${MASTERDIR}/Makefile"