aboutsummaryrefslogtreecommitdiff
path: root/archivers/rpm2cpio
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-04 18:55:52 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-04 18:55:52 +0000
commit3bf6e02d1f91feb115262765d63b7faa6eb08bd5 (patch)
treed3c93259ca48720afb208d8642d28984bbe788ba /archivers/rpm2cpio
parent320185af41bcd6dc11798be743d8b48b2aaae581 (diff)
downloadports-3bf6e02d1f91feb115262765d63b7faa6eb08bd5.tar.gz
ports-3bf6e02d1f91feb115262765d63b7faa6eb08bd5.zip
Support stage
Check for xz in path instead of checking osversion and looking for it in localbase Remove useless do-fetch target
Notes
Notes: svn path=/head/; revision=338673
Diffstat (limited to 'archivers/rpm2cpio')
-rw-r--r--archivers/rpm2cpio/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/archivers/rpm2cpio/Makefile b/archivers/rpm2cpio/Makefile
index ae82bc44267b..cea17b7f9ec6 100644
--- a/archivers/rpm2cpio/Makefile
+++ b/archivers/rpm2cpio/Makefile
@@ -14,26 +14,18 @@ COMMENT= Convert .rpm files for extraction with /usr/bin/cpio, needs just perl
NO_WRKSUBDIR= yes
USES= perl5
-NO_STAGE= yes
NO_BUILD= yes
REINPLACE_ARGS=
PLIST_FILES= bin/rpm2cpio.pl
-.include <bsd.port.pre.mk>
-
-.if ( (${OSVERSION} >= 900000 && ${OSVERSION} < 900012) || ${OSVERSION} < 800505 )
-RUN_DEPENDS+= ${LOCALBASE}/bin/xz:${PORTSDIR}/archivers/xz
-.endif
-
-do-fetch:
- @${DO_NADA}
+RUN_DEPENDS+= xz:${PORTSDIR}/archivers/xz
do-extract:
@${MKDIR} ${WRKSRC}
@${REINPLACE_CMD} -e 's|^#!/usr/bin/perl|#!${PERL}|' ${FILESDIR}/${PORTNAME} >${WRKDIR}/${PORTNAME}
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}.pl
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}.pl
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>