aboutsummaryrefslogtreecommitdiff
path: root/archivers/rpm2cpio
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /archivers/rpm2cpio
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadports-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
ports-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=403913
Diffstat (limited to 'archivers/rpm2cpio')
-rw-r--r--archivers/rpm2cpio/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/archivers/rpm2cpio/Makefile b/archivers/rpm2cpio/Makefile
index b0a6d587f105..0e6727d7825d 100644
--- a/archivers/rpm2cpio/Makefile
+++ b/archivers/rpm2cpio/Makefile
@@ -13,7 +13,8 @@ COMMENT= Convert .rpm files for extraction with /usr/bin/cpio, needs just perl
NO_WRKSUBDIR= yes
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ${PORTNAME}
NO_BUILD= yes
NO_ARCH= yes
REINPLACE_ARGS=
@@ -22,7 +23,7 @@ PLIST_FILES= bin/rpm2cpio.pl
do-extract:
@${MKDIR} ${WRKSRC}
- @${REINPLACE_CMD} -e 's|^#!/usr/bin/perl|#!${PERL}|' ${FILESDIR}/${PORTNAME} >${WRKDIR}/${PORTNAME}
+ @${CP} ${FILESDIR}/${PORTNAME} ${WRKDIR}/${PORTNAME}
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}.pl