aboutsummaryrefslogtreecommitdiff
path: root/archivers/rpm4
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2020-03-22 16:05:50 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2020-03-22 16:05:50 +0000
commit6ad44dd253fb630c2514fb0ea6a4cd82823cfa1a (patch)
tree1dabb1975397cc5a5270f4e4c6a662acc45dbd8c /archivers/rpm4
parent3fd8df47d888b7d076ab130d9fa3533b160545ea (diff)
downloadports-6ad44dd253fb630c2514fb0ea6a4cd82823cfa1a.tar.gz
ports-6ad44dd253fb630c2514fb0ea6a4cd82823cfa1a.zip
archivers/rpm4: Replace calls to xargs by gxargs
Latest version of archivers/rpm4 uses GNU specific option when calls xargs. This causes the proccess to fail. This commit adds misc/findutils as a run dependency and replaces xargs calls by its GNU variant gxargs. Also Bump portrevision. PR: 244606 Reported by: Brian Zou <zoujiaqing@gmail.com>
Notes
Notes: svn path=/head/; revision=528924
Diffstat (limited to 'archivers/rpm4')
-rw-r--r--archivers/rpm4/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index 29b7b6a4e427..356359505bab 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rpm
PORTVERSION= 4.15.1
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= http://ftp.rpm.org/releases/rpm-4.15.x/
PKGNAMESUFFIX= 4
@@ -16,7 +17,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpopt.so:devel/popt \
libnss3.so:security/nss \
libzstd.so:archivers/zstd
-RUN_DEPENDS= bash:shells/bash
+RUN_DEPENDS= bash:shells/bash \
+ gxargs:misc/findutils
USES= alias bdb compiler:openmp gmake iconv libarchive libtool \
lua:52+ pathfix pkgconfig shebangfix tar:bzip2
@@ -70,6 +72,12 @@ post-patch:
@${REINPLACE_CMD} -e 's:\.\./\.\./bin/::' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's/ __GLIBC__.*/& || defined(__FreeBSD__)/' \
${WRKSRC}/system.h
+ @${REINPLACE_CMD} -e 's/\<xargs\>/gxargs/g' ${WRKSRC}/scripts/brp-python-bytecompile \
+ ${WRKSRC}/scripts/brp-strip-static-archive \
+ ${WRKSRC}/scripts/check-buildroot \
+ ${WRKSRC}/scripts/check-rpaths \
+ ${WRKSRC}/scripts/find-debuginfo.sh \
+ ${WRKSRC}/scripts/vpkg-provides.sh
post-install-PYTHON-off:
@${RM} ${STAGEDIR}${PREFIX}/lib/rpm/pythondistdeps.py