aboutsummaryrefslogtreecommitdiff
path: root/archivers/rpm5
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-03-09 19:40:38 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-03-09 19:40:38 +0000
commite96188d0c88794161a4508f2a16698da04fbba36 (patch)
tree4daddee36eb0e3c64e2b7880ff03b09c67a25615 /archivers/rpm5
parentd35235fb7253100ff7da6c685955e50f7dc3c132 (diff)
downloadports-e96188d0c88794161a4508f2a16698da04fbba36.tar.gz
ports-e96188d0c88794161a4508f2a16698da04fbba36.zip
. Build and install API documentation if NOPORTDOCS isn't set.
. Bump PORTREVISION for this change.
Notes
Notes: svn path=/head/; revision=103452
Diffstat (limited to 'archivers/rpm5')
-rw-r--r--archivers/rpm5/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/archivers/rpm5/Makefile b/archivers/rpm5/Makefile
index 84a1b6b3d069..64049577ac83 100644
--- a/archivers/rpm5/Makefile
+++ b/archivers/rpm5/Makefile
@@ -6,6 +6,7 @@
PORTNAME= rpm
PORTVERSION= 4.0.4
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/ \
ftp://ftp.mirror.ac.uk/sites/ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/
@@ -20,6 +21,9 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
.if !exists(/usr/bin/bzip2)
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
+.endif
USE_LIBTOOL_VER=14
USE_GMAKE= yes
@@ -51,11 +55,23 @@ CONFIGURE_ARGS+=--without-db \
MAN1= gendiff.1
MAN8= rpm.8 rpm2cpio.8 rpmbuild.8
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's:%%LOCALBASE%%:${LOCALBASE}:' \
${WRKSRC}/configure ${WRKSRC}/beecrypt/configure
post-install:
+.if !defined(NOPORTDOCS)
+ # Install documentation
+ ${MKDIR} ${DOCSDIR}/apidocs/html
+ cd ${WRKSRC}/apidocs/html && ${FIND} . \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} \
+ ${DOCSDIR}/apidocs/html/
+.endif
+ # Run package installation script
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>