aboutsummaryrefslogtreecommitdiff
path: root/archivers/tardy/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2012-07-17 21:11:22 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2012-07-17 21:11:22 +0000
commitd92949bfe8b6ff419a6a07d712199b70b89b2f06 (patch)
treef0315661ffcf60d0606a0718a27897c50b81e41b /archivers/tardy/Makefile
parentb122d597380a87076a8cf9abe566124b6b99e81e (diff)
downloadports-d92949bfe8b6ff419a6a07d712199b70b89b2f06.tar.gz
ports-d92949bfe8b6ff419a6a07d712199b70b89b2f06.zip
Update to 1.26
Notes
Notes: svn path=/head/; revision=301041
Diffstat (limited to 'archivers/tardy/Makefile')
-rw-r--r--archivers/tardy/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/archivers/tardy/Makefile b/archivers/tardy/Makefile
index 7f300abe4429..44747fb2f9da 100644
--- a/archivers/tardy/Makefile
+++ b/archivers/tardy/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= tardy
-PORTVERSION= 1.25
+PORTVERSION= 1.26
+DISTVERSIONSUFFIX= .D001
CATEGORIES= archivers
-MASTER_SITES= CRITICAL
+MASTER_SITES= SF/tardy/${PORTVERSION}/
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Manipulate the file headers in tar archive files in various ways
@@ -17,7 +18,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs \
${LOCALBASE}/include/libiberty/libiberty.h:${PORTSDIR}/devel/gnulibiberty
-LIB_DEPENDS= explain.45:${PORTSDIR}/devel/libexplain
+LIB_DEPENDS= explain:${PORTSDIR}/devel/libexplain
GNU_CONFIGURE= yes
@@ -29,6 +30,14 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= tardy.1
PLIST_FILES= bin/tardy
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
+BUILD_DEPENDS+= lzma:${PORTSDIR}/archivers/xz
+.endif
+
post-patch:
.for var in CFLAGS LDFLAGS
@${REINPLACE_CMD} -e 's|^\(${var}\)\ =\ \(.*\)|\1 ?= \2|' \
@@ -39,4 +48,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/man1/${MAN1} ${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>