aboutsummaryrefslogtreecommitdiff
path: root/archivers/unfoo
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-13 13:41:42 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-13 13:41:42 +0000
commitf7548d9bc67cb647836e97c5489148014073f385 (patch)
treeb4b8813662c1000ee827ed149f08537321235038 /archivers/unfoo
parent5c711d524c745f29547f6c14e02148c5cfd3bf29 (diff)
downloadports-f7548d9bc67cb647836e97c5489148014073f385.tar.gz
ports-f7548d9bc67cb647836e97c5489148014073f385.zip
Add port archivers/unfoo:
Unfoo is a tiny sh(1) wrapper to simplify decompression of files. Supported archive types: tar, gzip, bzip2, ace, rar, zip, 7z. WWW: http://obsoleet.org/code/unfoo/ Author: Graham Forest <vitaminmoo@wza.us> Based on: Gentoo Portage
Notes
Notes: svn path=/head/; revision=197579
Diffstat (limited to 'archivers/unfoo')
-rw-r--r--archivers/unfoo/Makefile32
-rw-r--r--archivers/unfoo/distinfo3
-rw-r--r--archivers/unfoo/pkg-descr5
3 files changed, 40 insertions, 0 deletions
diff --git a/archivers/unfoo/Makefile b/archivers/unfoo/Makefile
new file mode 100644
index 000000000000..ee82a82700ad
--- /dev/null
+++ b/archivers/unfoo/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: unfoo
+# Date created: 13 August 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unfoo
+PORTVERSION= 1.0.6
+CATEGORIES= archivers
+MASTER_SITES= CENKES
+#http://obsoleet.org/code/unfoo/unfoo-1.0.6.sh
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Tiny sh(1) wrapper to simplify decompression of files
+
+RUN_DEPENDS= unace:${PORTSDIR}/archivers/unace \
+ unrar:${PORTSDIR}/archivers/unrar \
+ unzip:${PORTSDIR}/archivers/unzip \
+ 7z:${PORTSDIR}/archivers/p7zip
+
+NO_BUILD= yes
+USE_BZIP2= yes
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|/.*|/bin/sh|;s|==|=|' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/archivers/unfoo/distinfo b/archivers/unfoo/distinfo
new file mode 100644
index 000000000000..bd83cc2d7e49
--- /dev/null
+++ b/archivers/unfoo/distinfo
@@ -0,0 +1,3 @@
+MD5 (unfoo-1.0.6.tar.bz2) = 6de918e15b0d69de60bd9a904b623e25
+SHA256 (unfoo-1.0.6.tar.bz2) = ee1d45364be612226237389892889e0f3704e77fe71af2a1d231221d076deda2
+SIZE (unfoo-1.0.6.tar.bz2) = 1505
diff --git a/archivers/unfoo/pkg-descr b/archivers/unfoo/pkg-descr
new file mode 100644
index 000000000000..8f186822cfdd
--- /dev/null
+++ b/archivers/unfoo/pkg-descr
@@ -0,0 +1,5 @@
+Unfoo is a tiny sh(1) wrapper to simplify decompression of files.
+Supported archive types: tar, gzip, bzip2, ace, rar, zip, 7z.
+
+WWW: http://obsoleet.org/code/unfoo/
+Author: Graham Forest <vitaminmoo@wza.us>