aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-07-09 23:03:04 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-07-09 23:03:04 +0000
commit1cee02cf4d309efc7e5ef476d9099cda5ee02491 (patch)
tree26d61863bb38f999e069b8f9a0783086bf6f17b4 /archivers
parentda9be2fdd9744af85f375ef2e623ae5d43fd5ca9 (diff)
downloadports-1cee02cf4d309efc7e5ef476d9099cda5ee02491.tar.gz
ports-1cee02cf4d309efc7e5ef476d9099cda5ee02491.zip
archivers/xmill: fix build with clang
PR: 191372 Submitted by: tkato432 yahoo com
Notes
Notes: svn path=/head/; revision=361418
Diffstat (limited to 'archivers')
-rw-r--r--archivers/xmill/Makefile15
-rw-r--r--archivers/xmill/files/patch-XMill-CompressMan.cpp16
-rw-r--r--archivers/xmill/files/patch-XMill-PPMDI.cpp16
3 files changed, 23 insertions, 24 deletions
diff --git a/archivers/xmill/Makefile b/archivers/xmill/Makefile
index 6f0bed285028..ba48c6f288d6 100644
--- a/archivers/xmill/Makefile
+++ b/archivers/xmill/Makefile
@@ -10,16 +10,15 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Efficient compressor for XML
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKEFILE= makefile
USES= dos2unix zip
-DOS2UNIX_FILES= ${MAKEFILE} XMill/BZlib.cpp
-
-PLIST_FILES= bin/xcmill bin/xdemill bin/xmilltest bin/xmillexample \
- bin/xmillinspect bin/ppmzip
+DOS2UNIX_FILES= ${MAKEFILE} XMill/*.cpp
+MAKEFILE= makefile
PORTDOCS= *
PORTEXAMPLES= *
+PLIST_FILES= bin/xcmill bin/xdemill bin/xmilltest bin/xmillexample \
+ bin/xmillinspect bin/ppmzip
OPTIONS_DEFINE= DOCS EXAMPLES
@@ -30,11 +29,11 @@ post-patch:
do-install:
.for p in ${PLIST_FILES:T}
- ${INSTALL_PROGRAM} ${WRKSRC}/unix/${p} ${STAGEDIR}${PREFIX}/bin
+ (cd ${WRKSRC}/unix && ${INSTALL_PROGRAM} ${p} ${STAGEDIR}${PREFIX}/bin)
.endfor
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/documentation/* ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/documentation && ${INSTALL_DATA} * ${STAGEDIR}${DOCSDIR})
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${INSTALL_DATA} * ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/archivers/xmill/files/patch-XMill-CompressMan.cpp b/archivers/xmill/files/patch-XMill-CompressMan.cpp
index 0df8b5694305..4e281515351e 100644
--- a/archivers/xmill/files/patch-XMill-CompressMan.cpp
+++ b/archivers/xmill/files/patch-XMill-CompressMan.cpp
@@ -1,11 +1,11 @@
--- XMill/CompressMan.cpp.orig 2009-03-13 19:11:05.000000000 +0100
+++ XMill/CompressMan.cpp 2009-03-13 19:11:08.000000000 +0100
@@ -423,7 +423,7 @@
- UserCompressorFactory *compressor=compressorlist;
- while(compressor!=NULL)
- {
-- printf("%lu =>",(unsigned int)compressor);
-+ printf("%lu =>",(unsigned intptr_t)compressor);
- printf("%s\n",compressor->GetName());
- compressor=compressor->next;
- }
+ UserCompressorFactory *compressor=compressorlist;
+ while(compressor!=NULL)
+ {
+- printf("%lu =>",(unsigned int)compressor);
++ printf("%lu =>",(unsigned)(intptr_t)compressor);
+ printf("%s\n",compressor->GetName());
+ compressor=compressor->next;
+ }
diff --git a/archivers/xmill/files/patch-XMill-PPMDI.cpp b/archivers/xmill/files/patch-XMill-PPMDI.cpp
index 8080202fddc5..a2b72a53cc78 100644
--- a/archivers/xmill/files/patch-XMill-PPMDI.cpp
+++ b/archivers/xmill/files/patch-XMill-PPMDI.cpp
@@ -1,11 +1,11 @@
--- XMill/PPMDI.cpp.orig 2009-03-13 19:12:05.000000000 +0100
+++ XMill/PPMDI.cpp 2009-03-13 19:12:29.000000000 +0100
@@ -245,7 +245,7 @@
-
- cleanup:
- *outused = j;
-- *inused = inlen - (int)endptr + (int)src;
-+ *inused = inlen - (intptr_t)endptr + (intptr_t)src;
- return ret;
- }
-
+
+ cleanup:
+ *outused = j;
+- *inused = inlen - (int)endptr + (int)src;
++ *inused = inlen - (intptr_t)endptr + (intptr_t)src;
+ return ret;
+ }
+