aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2009-01-09 00:36:38 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2009-01-09 00:36:38 +0000
commit299ed585eb94d5ff8359bccec6af11116d4c1ccd (patch)
tree4f0fccd517f7366acb8751e522279d3e28153c0e /archivers
parent6ed3615ed497cb49984de99a244a79667e890bb3 (diff)
downloadports-299ed585eb94d5ff8359bccec6af11116d4c1ccd.tar.gz
ports-299ed585eb94d5ff8359bccec6af11116d4c1ccd.zip
New port zipmix version 20070221: Produce a .ZIP file from 2 other
ones with the best compressed files from each.
Notes
Notes: svn path=/head/; revision=225531
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/zipmix/Makefile29
-rw-r--r--archivers/zipmix/distinfo3
-rw-r--r--archivers/zipmix/files/Makefile7
-rw-r--r--archivers/zipmix/files/patch-zipmix.c20
-rw-r--r--archivers/zipmix/pkg-descr15
6 files changed, 75 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index fc648adc19cc..6f1ec1855c6a 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -176,6 +176,7 @@
SUBDIR += xpk
SUBDIR += zip
SUBDIR += zipios++
+ SUBDIR += zipmix
SUBDIR += zipper
SUBDIR += zoo
diff --git a/archivers/zipmix/Makefile b/archivers/zipmix/Makefile
new file mode 100644
index 000000000000..ce68a0824f75
--- /dev/null
+++ b/archivers/zipmix/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: zipmix
+# Date created: Fri Jan 9 2009 00:00:37 UTC
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zipmix
+DISTVERSION= 20070221
+CATEGORIES= archivers
+MASTER_SITES= http://www.advsys.net/ken/util/
+DISTNAME= ${PORTNAME}_src
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Produce a .ZIP file from 2 other ones with the best compressed files
+
+USE_DOS2UNIX= yes
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+pre-build:
+ @${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/archivers/zipmix/distinfo b/archivers/zipmix/distinfo
new file mode 100644
index 000000000000..08729d7bcfab
--- /dev/null
+++ b/archivers/zipmix/distinfo
@@ -0,0 +1,3 @@
+MD5 (zipmix_src.zip) = dc398e5d2d0d214d43bcd087025be13f
+SHA256 (zipmix_src.zip) = 34f049928f691be4ba3decd559654a052877b2cc377ebe78255398b532592b99
+SIZE (zipmix_src.zip) = 4759
diff --git a/archivers/zipmix/files/Makefile b/archivers/zipmix/files/Makefile
new file mode 100644
index 000000000000..045b71cc1c00
--- /dev/null
+++ b/archivers/zipmix/files/Makefile
@@ -0,0 +1,7 @@
+# $FreeBSD$
+
+PROG= zipmix
+
+NO_MAN= YES
+
+.include <bsd.prog.mk>
diff --git a/archivers/zipmix/files/patch-zipmix.c b/archivers/zipmix/files/patch-zipmix.c
new file mode 100644
index 000000000000..63900393d3e7
--- /dev/null
+++ b/archivers/zipmix/files/patch-zipmix.c
@@ -0,0 +1,20 @@
+--- zipmix.c.orig 2009-01-08 22:05:10.000000000 -0200
++++ zipmix.c 2009-01-08 22:10:30.000000000 -0200
+@@ -4,6 +4,17 @@
+ !if 0
+ #endif
+
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
++#if (defined(BSD) && (BSD >= 199306))
++#include <stdlib.h>
++
++#define min(a,b) MIN(a,b)
++#define max(a,b) MAX(a,b)
++#endif
++
+ #if defined(_WIN32)
+
+ #include <windows.h>
diff --git a/archivers/zipmix/pkg-descr b/archivers/zipmix/pkg-descr
new file mode 100644
index 000000000000..cc7bab0d6f50
--- /dev/null
+++ b/archivers/zipmix/pkg-descr
@@ -0,0 +1,15 @@
+[ excerpt from developer's web site with modifications ]
+
+Sometimes, when you run 2 different .ZIP programs on the same data
+(PKZIP & KZIP for example), some files get compressed better in one
+program, while other files get compressed better in the other.
+
+ZIPMIX will take the best files from each one and create a new
+output file, which is guaranteed to be equal to or smaller in size
+to both of the input files.
+
+ZIPMIX can also be used to perform boolean operations on ZIP files,
+such as merging 2 ZIP files together, or updating a new file (with
+some tricks).
+
+WWW: http://www.advsys.net/ken/utils.htm