aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-06-12 17:31:01 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-05-12 10:01:16 +0000
commit5aa75e1ca0fca26372479bd36773428e2c24f1e4 (patch)
tree811795d58c948edcc29b697c3bf8195dbb72b99e /archivers
parenta80217170c4651b4a2d84d8aee69da1194b3b76a (diff)
downloadports-5aa75e1ca0fca26372479bd36773428e2c24f1e4.tar.gz
ports-5aa75e1ca0fca26372479bd36773428e2c24f1e4.zip
Linuxulator ports: Introduce Rocky Linux 9.
Sponsored by: Serenity Cybersecurity, LLC Co-authored-by: Dima Panov <fluffy@FreeBSD.org>
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile2
-rw-r--r--archivers/linux-rl9-brotli/Makefile18
-rw-r--r--archivers/linux-rl9-brotli/distinfo7
-rw-r--r--archivers/linux-rl9-brotli/pkg-plist.amd6410
-rw-r--r--archivers/linux-rl9-lz4/Makefile22
-rw-r--r--archivers/linux-rl9-lz4/distinfo11
-rw-r--r--archivers/linux-rl9-lz4/pkg-plist.amd6415
7 files changed, 85 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index f61551f48676..54ccaf3f66b3 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -72,6 +72,8 @@
SUBDIR += libzip
SUBDIR += libzippp
SUBDIR += linux-c7-lz4
+ SUBDIR += linux-rl9-brotli
+ SUBDIR += linux-rl9-lz4
SUBDIR += lizard
SUBDIR += lrzip
SUBDIR += lua-lzlib
diff --git a/archivers/linux-rl9-brotli/Makefile b/archivers/linux-rl9-brotli/Makefile
new file mode 100644
index 000000000000..054d168b236b
--- /dev/null
+++ b/archivers/linux-rl9-brotli/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= brotli
+PORTVERSION= 1.0.9
+DISTVERSIONSUFFIX= -6.el9
+CATEGORIES= archivers linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Generic-purpose lossless compression algorithm (Rocky Linux ${LINUX_DIST_VER})
+WWW= https://github.com/google/brotli
+
+USES= cpe linux:rl9
+USE_LDCONFIG= yes
+USE_LINUX_RPM= yes
+
+LIB_DISTNAMES= libbrotli-${PORTVERSION}${DISTVERSIONSUFFIX}
+
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/archivers/linux-rl9-brotli/distinfo b/archivers/linux-rl9-brotli/distinfo
new file mode 100644
index 000000000000..8f0dc8641d09
--- /dev/null
+++ b/archivers/linux-rl9-brotli/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1686557029
+SHA256 (rocky/l/libbrotli-1.0.9-6.el9.aarch64.rpm) = ce7a09cb403e78979d13513a9b5369a313b6da87612280ae8c8c0d3baafd7192
+SIZE (rocky/l/libbrotli-1.0.9-6.el9.aarch64.rpm) = 319923
+SHA256 (rocky/l/libbrotli-1.0.9-6.el9.x86_64.rpm) = a7d211e1059231df8d27fa8f340ac47bdef29b016a49d8a482b13a1f5b4f6c89
+SIZE (rocky/l/libbrotli-1.0.9-6.el9.x86_64.rpm) = 320595
+SHA256 (rocky/b/brotli-1.0.9-6.el9.src.rpm) = a9675cc4978a876331d6d8fa79da4fbcddde654201dc44a7b057141019b8d5b3
+SIZE (rocky/b/brotli-1.0.9-6.el9.src.rpm) = 497487
diff --git a/archivers/linux-rl9-brotli/pkg-plist.amd64 b/archivers/linux-rl9-brotli/pkg-plist.amd64
new file mode 100644
index 000000000000..3c0d04ad3db4
--- /dev/null
+++ b/archivers/linux-rl9-brotli/pkg-plist.amd64
@@ -0,0 +1,10 @@
+usr/lib/.build-id/07/2fd8429f1bf5f132554b0aa18976ecc4ddc6a3
+usr/lib/.build-id/26/a67f69a8cb6463bc93af9c8580babd59c3bb86
+usr/lib/.build-id/4b/fec349d16eb88bf0bc18a6beb3dadd9005b428
+usr/lib64/libbrotlicommon.so.1
+usr/lib64/libbrotlicommon.so.1.0.9
+usr/lib64/libbrotlidec.so.1
+usr/lib64/libbrotlidec.so.1.0.9
+usr/lib64/libbrotlienc.so.1
+usr/lib64/libbrotlienc.so.1.0.9
+usr/share/licenses/libbrotli/LICENSE
diff --git a/archivers/linux-rl9-lz4/Makefile b/archivers/linux-rl9-lz4/Makefile
new file mode 100644
index 000000000000..733e8cd28b89
--- /dev/null
+++ b/archivers/linux-rl9-lz4/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= lz4
+PORTVERSION= 1.9.3
+DISTVERSIONSUFFIX= -5.el9
+CATEGORIES= archivers linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= LZ4 compression library and utilities (Rocky Linux ${LINUX_DIST_VER})
+WWW= https://lz4.github.io/lz4/
+
+USES= cpe linux:rl9
+USE_LDCONFIG= yes
+USE_LINUX_RPM= yes
+CPE_VENDOR= lz4_project
+
+BIN_DISTNAMES= ${DISTNAME}
+LIB_DISTNAMES= lz4-libs-${PORTVERSION}${DISTVERSIONSUFFIX}
+
+DESCR= ${.CURDIR}/../liblz4/pkg-descr
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.mk>
diff --git a/archivers/linux-rl9-lz4/distinfo b/archivers/linux-rl9-lz4/distinfo
new file mode 100644
index 000000000000..81c61e7911a8
--- /dev/null
+++ b/archivers/linux-rl9-lz4/distinfo
@@ -0,0 +1,11 @@
+TIMESTAMP = 1686578411
+SHA256 (rocky/l/lz4-1.9.3-5.el9.aarch64.rpm) = c05d506dd1159cf36a6bf32253cfe80769e12e13cd91a3d1151ba22617212ad3
+SIZE (rocky/l/lz4-1.9.3-5.el9.aarch64.rpm) = 58506
+SHA256 (rocky/l/lz4-1.9.3-5.el9.x86_64.rpm) = aff0266d25b25672c00d071676e491d4d9dedb06fcaf1a9c8432b658e514e211
+SIZE (rocky/l/lz4-1.9.3-5.el9.x86_64.rpm) = 58990
+SHA256 (rocky/l/lz4-libs-1.9.3-5.el9.aarch64.rpm) = 8640e8b3ba387e5ec9036e89903add891d7c960bbf0378797746cb43e0e2208f
+SIZE (rocky/l/lz4-libs-1.9.3-5.el9.aarch64.rpm) = 68066
+SHA256 (rocky/l/lz4-libs-1.9.3-5.el9.x86_64.rpm) = 60f82f4c3f76a543ab247acb37cb439d9de9e40c410ac2f315d6805717d6283e
+SIZE (rocky/l/lz4-libs-1.9.3-5.el9.x86_64.rpm) = 68333
+SHA256 (rocky/l/lz4-1.9.3-5.el9.src.rpm) = 7435ed18c0f9182fe60186984d21bbb2d952f55d468344e8b37c1901419798e3
+SIZE (rocky/l/lz4-1.9.3-5.el9.src.rpm) = 331738
diff --git a/archivers/linux-rl9-lz4/pkg-plist.amd64 b/archivers/linux-rl9-lz4/pkg-plist.amd64
new file mode 100644
index 000000000000..66a6514aa3f9
--- /dev/null
+++ b/archivers/linux-rl9-lz4/pkg-plist.amd64
@@ -0,0 +1,15 @@
+usr/bin/lz4
+usr/bin/lz4c
+usr/bin/lz4cat
+usr/bin/unlz4
+usr/lib/.build-id/34/ac120d87bf3ef698c5478da3f6af07a091bb85
+usr/lib/.build-id/8f/ca9ddfd58ba57f36602b0c1d03ad21bacc55df
+usr/lib64/liblz4.so.1
+usr/lib64/liblz4.so.1.9.3
+%%PORTDOCS%%usr/share/doc/lz4-libs/LICENSE
+%%PORTDOCS%%usr/share/doc/lz4/NEWS
+usr/share/licenses/lz4/COPYING
+usr/share/man/man1/lz4.1.gz
+usr/share/man/man1/lz4c.1.gz
+usr/share/man/man1/lz4cat.1.gz
+usr/share/man/man1/unlz4.1.gz