aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-06-11 20:59:05 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-06-11 21:02:49 +0000
commit665b149d2692ff6926a092568304091995e07d39 (patch)
tree43733e6164a8fac2635af7542a26e80c2524c28c /archivers
parent86d3a1352320828ae4d68b3a49ea1916d4ee3389 (diff)
downloadports-665b149d2692ff6926a092568304091995e07d39.tar.gz
ports-665b149d2692ff6926a092568304091995e07d39.zip
*/*php82*: Welcome php 8.2.0 Alpha 1
Please DO NOT use this version in production, it is an early test version. port-committers@ please DO NOT mark your ports IGNORE_WITH_PHP=82. A build is running to check all php ports with php82 and will be committed in batch tomorrow. Sponsored by: Bounce Experts
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile4
-rw-r--r--archivers/php82-bz2/Makefile7
-rw-r--r--archivers/php82-phar/Makefile7
-rw-r--r--archivers/php82-phar/files/patch-config.m441
-rw-r--r--archivers/php82-zip/Makefile7
-rw-r--r--archivers/php82-zlib/Makefile7
-rw-r--r--archivers/php82-zlib/files/patch-zlib.c10
7 files changed, 83 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 6d4551be7eb7..713ea89e298d 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -162,9 +162,13 @@
SUBDIR += php80-zip
SUBDIR += php80-zlib
SUBDIR += php81-bz2
+ SUBDIR += php82-bz2
SUBDIR += php81-phar
+ SUBDIR += php82-phar
SUBDIR += php81-zip
+ SUBDIR += php82-zip
SUBDIR += php81-zlib
+ SUBDIR += php82-zlib
SUBDIR += pigz
SUBDIR += pixz
SUBDIR += plzip
diff --git a/archivers/php82-bz2/Makefile b/archivers/php82-bz2/Makefile
new file mode 100644
index 000000000000..216b54067f8c
--- /dev/null
+++ b/archivers/php82-bz2/Makefile
@@ -0,0 +1,7 @@
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php82
+
+PKGNAMESUFFIX= -bz2
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php82-phar/Makefile b/archivers/php82-phar/Makefile
new file mode 100644
index 000000000000..f0600ea23347
--- /dev/null
+++ b/archivers/php82-phar/Makefile
@@ -0,0 +1,7 @@
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php82
+
+PKGNAMESUFFIX= -phar
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php82-phar/files/patch-config.m4 b/archivers/php82-phar/files/patch-config.m4
new file mode 100644
index 000000000000..1aba3bd9a5a8
--- /dev/null
+++ b/archivers/php82-phar/files/patch-config.m4
@@ -0,0 +1,41 @@
+--- config.m4.orig 2016-06-21 19:56:50 UTC
++++ config.m4
+@@ -4,8 +4,38 @@ dnl config.m4 for extension phar
+ PHP_ARG_ENABLE(phar, for phar archive support,
+ [ --disable-phar Disable phar support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir PHAR: pcre install prefix], no, no)
++
++
+ if test "$PHP_PHAR" != "no"; then
++
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ PHP_NEW_EXTENSION(phar, util.c tar.c zip.c stream.c func_interceptors.c dirstream.c phar.c phar_object.c phar_path_check.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
++ PHP_HASH=yes
+ AC_MSG_CHECKING([for phar openssl support])
+ if test "$PHP_HASH_SHARED" != "yes"; then
+ if test "$PHP_HASH" != "no"; then
diff --git a/archivers/php82-zip/Makefile b/archivers/php82-zip/Makefile
new file mode 100644
index 000000000000..5d9133ebe88f
--- /dev/null
+++ b/archivers/php82-zip/Makefile
@@ -0,0 +1,7 @@
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php82
+
+PKGNAMESUFFIX= -zip
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php82-zlib/Makefile b/archivers/php82-zlib/Makefile
new file mode 100644
index 000000000000..5b4e4ff90931
--- /dev/null
+++ b/archivers/php82-zlib/Makefile
@@ -0,0 +1,7 @@
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php82
+
+PKGNAMESUFFIX= -zlib
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php82-zlib/files/patch-zlib.c b/archivers/php82-zlib/files/patch-zlib.c
new file mode 100644
index 000000000000..be02c50d1df6
--- /dev/null
+++ b/archivers/php82-zlib/files/patch-zlib.c
@@ -0,0 +1,10 @@
+--- zlib.c.orig 2016-06-21 19:57:08 UTC
++++ zlib.c
+@@ -1480,6 +1480,7 @@ static PHP_MSHUTDOWN_FUNCTION(zlib)
+ /* {{{ PHP_RINIT_FUNCTION */
+ static PHP_RINIT_FUNCTION(zlib)
+ {
++ ZLIBG(output_compression) = 0;
+ ZLIBG(compression_coding) = 0;
+ if (!ZLIBG(handler_registered)) {
+ ZLIBG(output_compression) = ZLIBG(output_compression_default);