aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2018-11-08 23:19:03 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2018-11-08 23:19:03 +0000
commit7270e4860f3f46d8ff284179061c3d68292930e4 (patch)
tree932950adeb16f3c4479903d84d5486f0a78a548d /archivers
parent4c4f74caff8909cbdf65115d3bd83d08f28495c8 (diff)
downloadports-7270e4860f3f46d8ff284179061c3d68292930e4.tar.gz
ports-7270e4860f3f46d8ff284179061c3d68292930e4.zip
Add maxcso, ISO to CSO compressor for PSP/PS2 emulators
PR: 224638 Submitted by: Greg V <greg@unrelenting.technology>
Notes
Notes: svn path=/head/; revision=484487
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/maxcso/Makefile27
-rw-r--r--archivers/maxcso/distinfo3
-rw-r--r--archivers/maxcso/files/patch-Makefile23
-rw-r--r--archivers/maxcso/pkg-descr5
5 files changed, 59 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 86548eedffa7..ad2c507c6fe5 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -88,6 +88,7 @@
SUBDIR += lzop
SUBDIR += makeself
SUBDIR += mar
+ SUBDIR += maxcso
SUBDIR += minizip
SUBDIR += mscompress
SUBDIR += mtf
diff --git a/archivers/maxcso/Makefile b/archivers/maxcso/Makefile
new file mode 100644
index 000000000000..5cac13f0cda2
--- /dev/null
+++ b/archivers/maxcso/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= maxcso
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.10.0
+CATEGORIES= archivers
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= Fast ISO to CSO compressor for PSP and PS2 emulators
+
+LICENSE= ISCL
+
+LIB_DEPENDS= libuv.so:devel/libuv \
+ liblz4.so:archivers/liblz4 \
+ libzopfli.so:archivers/zopfli
+
+USES= gmake pkgconfig compiler:c++11-lang
+
+USE_GITHUB= yes
+GH_ACCOUNT= unknownbrackets
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/archivers/maxcso/distinfo b/archivers/maxcso/distinfo
new file mode 100644
index 000000000000..57898aea5ffa
--- /dev/null
+++ b/archivers/maxcso/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1541531490
+SHA256 (unknownbrackets-maxcso-v1.10.0_GH0.tar.gz) = 8fc56ab96536c0b12f890b34a83b4c4a5c1013756f8664037313132b7c2515eb
+SIZE (unknownbrackets-maxcso-v1.10.0_GH0.tar.gz) = 3170809
diff --git a/archivers/maxcso/files/patch-Makefile b/archivers/maxcso/files/patch-Makefile
new file mode 100644
index 000000000000..d2e6509c5f05
--- /dev/null
+++ b/archivers/maxcso/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig 2018-11-08 20:43:35 UTC
++++ Makefile
+@@ -5,6 +5,9 @@ CFLAGS += -W -Wall -Wextra -O2 -Wno-implicit-function-
+ CXXFLAGS += -W -Wall -Wextra -std=c++11 -O2 -Izopfli/src -I7zip -DNDEBUG=1 \
+ -Wno-unused-parameter -pthread
+
++CFLAGS += $(shell pkg-config --cflags libuv liblz4)
++CXXFLAGS += $(shell pkg-config --cflags libuv liblz4)
++
+ SRC_CXX_SRC = $(wildcard src/*.cpp)
+ SRC_CXX_OBJ = $(SRC_CXX_SRC:.cpp=.o)
+ CLI_CXX_SRC = $(wildcard cli/*.cpp)
+@@ -23,8 +26,8 @@ ZOPFLI_C_OBJ = $(ZOPFLI_C_SRC:.c=.o)
+ %.o: %.c
+ $(CC) -c $(CFLAGS) -o $@ $<
+
+-maxcso: $(SRC_CXX_OBJ) $(CLI_CXX_OBJ) $(ZOPFLI_C_OBJ) 7zip/7zip.a
+- $(CXX) -o $@ $(CXXFLAGS) $^ -luv -llz4 -lz
++maxcso: $(SRC_CXX_OBJ) $(CLI_CXX_OBJ) 7zip/7zip.a
++ $(CXX) -o $@ $(CXXFLAGS) $^ $(shell pkg-config --libs libuv liblz4) -lzopfli -lz
+
+ 7zip/7zip.a:
+ $(MAKE) -C 7zip 7zip.a
diff --git a/archivers/maxcso/pkg-descr b/archivers/maxcso/pkg-descr
new file mode 100644
index 000000000000..08f271ccf0ff
--- /dev/null
+++ b/archivers/maxcso/pkg-descr
@@ -0,0 +1,5 @@
+A fast ISO to CSO compression program for use with PSP (PlayStation Portable)
+and PS2 (PlayStation 2) emulators, which uses multiple algorithms for best
+compression ratio.
+
+WWW: https://github.com/unknownbrackets/maxcso