aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2021-11-24 12:59:56 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2021-11-24 13:04:58 +0000
commitb8422634279eb3698f3d3fe5f0db532675ab39b5 (patch)
treed52b6403ae35b4eb798a86309266b3c1694bc6b9 /archivers
parentfc6a3122a3b859f8a34f26c6d079fa34ad418af5 (diff)
downloadports-b8422634279eb3698f3d3fe5f0db532675ab39b5.tar.gz
ports-b8422634279eb3698f3d3fe5f0db532675ab39b5.zip
archivers/libarchive: Update to 3.5.2
Use GitHub as primary MASTER_SITE and libarchive.org as fallback Enable Zstandard compression support by default Use xz tarball instead of gz (smaller size) Remove entries for DESC that are already defined in ports framework Disable static library Do some rearrangement of Makefile for readability Changelog: https://github.com/libarchive/libarchive/releases/tag/v3.5.2 Approved by: arrowd (mentor), glewis (maintainer) Differential Revision: https://reviews.freebsd.org/D32988
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libarchive/Makefile30
-rw-r--r--archivers/libarchive/distinfo6
2 files changed, 18 insertions, 18 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 17edf20b9d2d..de51922736a9 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -1,8 +1,9 @@
PORTNAME= libarchive
-PORTVERSION= 3.5.1
+DISTVERSION= 3.5.2
PORTEPOCH= 1
CATEGORIES= archivers
-MASTER_SITES= https://libarchive.org/downloads/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/ \
+ https://libarchive.org/downloads/
MAINTAINER= glewis@FreeBSD.org
COMMENT= Library to create and read several streaming archive formats
@@ -13,33 +14,28 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:textproc/expat2
OPTIONS_DEFINE= LZ4 LZO ZSTD
-OPTIONS_DEFAULT=LZ4 OPENSSL
+OPTIONS_DEFAULT=LZ4 ZSTD OPENSSL
-OPTIONS_RADIO+= CRYPTO
+OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= OPENSSL MBEDTLS NETTLE
CRYPTO_DESC= Crypto and hashing support
-LZ4_DESC= Support lz4 compression via liblz4
-LZO_DESC= Support lzo compression via liblzo2
-MBEDTLS_DESC= Crypto support from mbedTLS
-NETTLE_DESC= Crypto support from Nettle
-OPENSSL_DESC= Crypto support from OpenSSL
-ZSTD_DESC= Support zstd compression
-
-USES= cpe iconv libtool localbase:ldflags pathfix
+NETTLE_DESC= Crypto support via Nettle
+
+USES= cpe iconv libtool localbase:ldflags pathfix tar:xz
GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
+
+INSTALL_TARGET= install-strip
TEST_TARGET= check
-CONFIGURE_ARGS= --without-xml2
+CONFIGURE_ARGS= --disable-static --without-xml2
PLIST_FILES= bin/bsdcat \
bin/bsdcpio \
bin/bsdtar \
include/archive.h \
include/archive_entry.h \
- lib/libarchive.a \
lib/libarchive.so \
lib/libarchive.so.13 \
lib/libarchive.so.1${PORTVERSION} \
@@ -91,16 +87,20 @@ PLIST_FILES= bin/bsdcat \
LZO_LIB_DEPENDS= liblzo2.so:archivers/lzo2
LZO_CONFIGURE_WITH= lzo2
+
LZ4_LIB_DEPENDS= liblz4.so:archivers/liblz4
LZ4_CONFIGURE_WITH= lz4
+
ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
ZSTD_CONFIGURE_WITH= zstd
NETTLE_LIB_DEPENDS= libnettle.so:security/nettle
NETTLE_CONFIGURE_WITH= nettle
+
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_WITH= openssl
OPENSSL_CONFIGURE_OFF= --without-openssl
+
MBEDTLS_LIB_DEPENDS= libmbedtls.so:security/mbedtls
MBEDTLS_CONFIGURE_WITH= mbedtls
diff --git a/archivers/libarchive/distinfo b/archivers/libarchive/distinfo
index 878015f641aa..2cf5a46d0fec 100644
--- a/archivers/libarchive/distinfo
+++ b/archivers/libarchive/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1614043326
-SHA256 (libarchive-3.5.1.tar.gz) = 9015d109ec00bb9ae1a384b172bf2fc1dff41e2c66e5a9eeddf933af9db37f5a
-SIZE (libarchive-3.5.1.tar.gz) = 7008338
+TIMESTAMP = 1636759090
+SHA256 (libarchive-3.5.2.tar.xz) = f0b19ff39c3c9a5898a219497ababbadab99d8178acc980155c7e1271089b5a0
+SIZE (libarchive-3.5.2.tar.xz) = 4905416